Edit Rtorrent.rc


#1

Hello :slight_smile:

I have tried to install this AMC script for filebot. So i can make an automated setup for Rtorrent and Plex.
https://www.filebot.net/forums/viewtopic.php?f=4&t=215#p5316

But when i come to the last point on installing the script for Rtorrent. I can’t fint Rtorent.rc any where?.
i’m not an expert in console or Linux. That’s why i chose the Quickbox setup :slight_smile:

Edit ~/.rtorrent.rc and add an event.download.finished key

echo ‘system.method.set_key=event.download.finished,filebot,"execute={’pwd/rtorrent-postprocess.sh’,$d.get_base_path=,$d.get_name=,$d.get_custom1=}"’ >> ~/.rtorrent.rc

Can some one please help me? :slight_smile:


#2

Hello @Jesjor,

.rtorrent.rc file is hidden with ls command, you need to do an ls -al to see it.

You need to log on with the user created during the QB installation script and :

To see your .rtorrent.rc file : ls -al ~/
To edit your .rtorrent.rc file : nano ~/.rtorrent.rc


#3

Thanks. Now i can see the file.

After i added the event key in Rtorrent.RC. it wont stat up any more :confused:
I get this “red” button. And no option to connect at Rutorrent.


#4

Remove what you put into the file and try to start rtorrent again with :

systemctl restart [email protected] (in case of, the .rtorrent.rc template file : here)

If that works, make a copy of your .rtorrent.rc :

cd ~/
cp .rtorrent.rc .rtorrent.rc.bkp

After that, you can modify your .rtorrent.rc file to make some modifications.
If it fails to start rtorrent, simply do :

rm .rtorrent.rc
cp .rtorrent.rc.bkp .rtorrent.rc

And restart rtorrent for your user again :wink:


#5

Did you succeed to restart rtorrent @Jesjor ?


#6

I hevent tried yet. I havent been online since.
I will try in an hour again :slight_smile:
But thanks so far :slight_smile:


#7

Rtorrent works again. But the script wont run :frowning: