Downgrading rtorrent?

rtorrent

#21

If you were to run the setup again would it delete the data on the server already? Won’t be making any changes yet but curious.


#22

It shouldn’t delete anything as the directories already exists. Since a users /home is already available it will more than likely post errors that it’s already present. I’ll run a sample as soon as I have time… if anyone else wants to sample this theory or write a up/down script for rtorrent, be my guest :wink:


#23

would take a snapshot of the session folder so you dont have to redo everything in rutorrent should the setup mess with it :slight_smile:

just as a precursion…


#24

Any news about a “more cool” solution to downgrading rtorrent (instead of reinstall above the old one)??


#25

I am trying to get around to this as soon as possible as I know it has been heavily requested. I really hope that I’ll have time this weekend, but I cannot make any promises as the weather is finally nice outside!!!


#26

Ok many thanks JM!! at least on my part, there is no hurry! so…no problem!!

Anyway…has someone tried to downgrade by installing the old version over the new one?? if yes, do you have had problems?? everything works perfectly?? Please share any useful information, thanks!


#27

I’d appreciate hearing anyone else’s use of this option as well. :sweat_smile:


#28

I somehow managed to downgrade from 0.9.6 to 0.9.4

I’ll need to run it a few more times just to make sure! :slight_smile:


#29

Thanks for sharing Bate!


#30

I actually got this working by reinstalling libtorrent and rtorrent, but it was a normal seedbox setup and not quickbox, but it might work. I had rtorrent 0.9.6 and libtorrent 0.13.6 and reinstalled to rtorrent 0.9.4 libtorrent 0.13.4 and after it was done and i started rtorrent, it was using the latest installed. So it might be easy fix by only doing a reinstall and it will use the latest installed.

If someone wants to try with quickbox, here are the steps (login as root)

svn co https://svn.code.sf.net/p/xmlrpc-c/code/stable xmlrpc
curl http://rtorrent.net/downloads/libtorrent-0.13.4.tar.gz | tar xz
curl http://rtorrent.net/downloads/rtorrent-0.9.4.tar.gz | tar xz
cd xmlrpc
./configure --prefix=/usr --disable-cplusplus
make
sudo make install
cd ../libtorrent-0.13.4
./autogen.sh
./configure --prefix=/usr
make -j2
sudo make install
cd ../rtorrent-0.9.4
./autogen.sh
./configure --prefix=/usr --with-xmlrpc-c
make -j2
sudo make install
sudo ldconfig

Dont forget to stop rtorrent before doing this, not sure if it can be running while reinstalling. Safest to stop it at first.


Possible to downgrade rutorrent on QuickBox
#31

This worked fine for me. Though I was upgrading from 0.9.2.

Links on Dashboard are working fine.


#32

Bumped this to a Feature Request so it doesn’t fall off the radar again. :wink: