DNS working with QuickBox


#1

Hi, I follwed the instructions and after setting up the SSL certificate I selected the secure mode, where HTTP requests should redirect to HTTPS, but when I type my server address with HTTP it will show me the Apache2 Ubuntu Default Page. If acess it through HTTPS it works just fine with the Let’s Encrypt SSL certificate. What should I do?


#2

make sure to follow all of the instructions please this is addressed in there.

sed -i "s|DocumentRoot /var/www/html|DocumentRoot /srv/rutorrent/home/|g" /etc/apache2/sites-enabled/000-default-le-ssl.conf && service apache2 restart


#3

hey i get this

Domain: mycloud.xxxxxx.xyz
Type: tls
Detail: Failed to connect to 104.27.183.109:443 for TLS-SNI-01
challenge

Domain: xxxxx.xyz
Type: tls
Detail: Failed to connect to 104.27.183.109:443 for TLS-SNI-01
challenge

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address. Additionally, please check that
you have an up-to-date TLS configuration that allows the server to
communicate with the Certbot client.


#4

means your dns is not set up right. it has to be able to connect to your domain using the dns. if your domain is not set up correctly then it will not be able to talk to the server when it asks for the tls cert from the dns.


#5

i set it up using cloudflare , i did an A record, should i try another type?


#6

I did. It doesn’t works. When I access via HTTPS it works fine, but when I access it via HTTP instead of redirecting to HTTPs it shows the Apache Default page.


#7

Ensure that if you are using CloudFlare you do not have it proxying through CloudFlare. Take note of the little cloud icon next too the A-Record… ensure that it is greyed out. If you try to create the LE certificate while proxying via CloudFlare it will deny the request as it is attempting to use a CloudFlare IP.


#8

Have you done a full clearing of your browser cache? Ctrl + f5
It is quite possible you are just caching the old apache splash page. This seems to be your case as you said it connects fine via https. I just installed LE on a new server and the issue does not exist. Additionally, QuickBox defaults your connection to a secure https:… did you modify your apache files and/or .htaccess to remove this?


#9

Man , your the master, it worked, thank you :slight_smile: , also i had the same problem as Potter and simply restarting apache fixed it.


#10

It’s not the cache. It appears when I access from other computers.
When i tried to install the SSL certificate and I got to this part of the tutorial:

There were 3 options to select. I selected 000-default.conf and it didn’t work, probably the DNS was still updating so I tried later and selected the same 000-default.conf and it worked. I selected the secure option to have all connections through HTTPS and I runned the command:

sed -i “s|DocumentRoot /var/www/html|DocumentRoot /srv/rutorrent/home/|g” /etc/apache2/sites-enabled/000-default-le-ssl.conf && service apache2 restart

Then I checked: the SSL was working but the non-ssl address was showing the Apache Default Page.
Is there any config file I could check if something went wrong the first time I tried?


#11

You do realize if you select to secure all options, rather than the “easy” option it will in fact, remove your non-ssl defaults? The problem is that the option you selected only permits secure transactions and anything http is default to the apache default directory of /var/www.


#12

Is there any way to fix this without having to reinstall everything? I tried reinstalling the SSL certificate and selected the easy option but the screen asking to choose 000-default.conf doesn’t appear anymore and nothing changed.


#13

If you like, feel free to shoot me a PM with your server details and I will work on patching up your configs.


#14

you could try rerunning the install of it i did it and it fixed it.


#15

The only problem is that if 5 attempts/reinstalls are met, it will lock you out of the auth chain for 7 days.