Disk Status is not working


#1

Hi,

I have installed Quickbox and the Disk Status is not working. What i mean is it show nothing at all. During installation i selected the /home mount option but when i ssh into my server and change to the /root directorhy i see that Quickbox seems to be installed in the /root directory. My /root directory has the following files when i do a ls -l :

mantax:~# ls -l                                                                                                            
total 712K                                                                                                                 
drwxr-xr-x 2 root root 4.0K Jan 12 05:25 bin
-rw-r--r-- 1 root root  239 Jan 12 05:25 information.info                                                                  
-rw-r--r-- 1 root root   78 Jan 12 05:25 mantax.info                                                                       
-rw-r--r-- 1 root root   15 Jan 12 04:59 mantax.info.db                                                                    
drwxr-xr-x 8 root root 4.0K Jan 12 04:57 QuickBox
-rw-r--r-- 1 root root 680K Jan 12 05:26 quickbox.1196.log                                                                 
drwxr-xr-x 6 root root 4.0K Jan 12 05:25 share
-rw-r--r-- 1 root root   14 Jan 12 05:25 tz.txt          

The user that was being created during the installation is called mantax and has the following in its /home/mantax directory when i do a ls -l :

mantax:/home/mantax# ls -l                                                                                                 
total 12K                                                                                                                  
drwxr-xr-x 2 mantax mantax 4.0K Jan 12 05:25 dwatch
drwxr-xr-x 2 mantax mantax 4.0K Jan 12 05:25 rwatch
drwxr-xr-x 4 mantax mantax 4.0K Jan 12 05:25 torrents            

Also my output for the /etc/fstab is:

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/vda1       /               ext4    usrjquota=aquota.user,jqfmt=vfsv1,errors=remount-ro 1       1
/dev/vda2       none            swap    sw              0       0

The System is a VPN running Ubuntu 16.04 LTS and is a KVM provisioned VPS.

Any help is appreciated

George


Disk space not showing in Dashboard
#2

Try with box uninstall quotas


#4

I issued the command via the terminal as root user as you said:

box uninstall quotas

I also restarted the VPS but again the Disk Status is empty. It says only Free: GB & Used: GB and Size: GB … there is no number indicating how much GB for every category…

Shure that it was correct to issue the above command?

Thanks in advance

George


#5

After the box uninstall quotas use this command setdisk


#7

It asks me for:

Username:

I am currently logged in as root should i enter here now root or should i enter the user that was created during the quickbox install? The user that was created is called mantax and has a directory at location /home/mantax … Also during the Quickbox installation i selected the /home mount option.

Thanks for the help!!!

George


#8

No you should pick the name of your QB user


#10

Ok i have done that. Prior to this i also issued the command:

df -h

to see how much GB i have available. The VPS has a clean install of Ubuntu 16.04 LTS and of Quickbox… nothing else. The output of the above was:

(1:56)# df -h
Filesystem     Type      Size  Used Avail Use% Mounted on
udev           devtmpfs  981M     0  981M   0% /dev
tmpfs          tmpfs     201M  5.6M  195M   3% /run
/dev/vda1      ext4      916G  3.4G  867G   1% /
tmpfs          tmpfs    1001M     0 1001M   0% /dev/shm
tmpfs          tmpfs     5.0M     0  5.0M   0% /run/lock
tmpfs          tmpfs    1001M     0 1001M   0% /sys/fs/cgroup
tmpfs          tmpfs     201M     0  201M   0% /run/user/0
1531/2000MB	0.00 0.00 0.00 1/185 2204
[2172:2135 0:57] 03:18:40 Thu Jan 12 [[email protected]] ~

What confuses me here is that i have a VPS with 1TB storage so it seems i have a storage of only 916GB… from this 3.4GB is used and i have left only 867GB ??? Doesnt matter i continue and i typed the setdisk command, i entered the user mantax and when i was asked about how much GB i entered 867GB because above i saw only 867GB available to me.

setdisk

The output was:

(1:57)# setdisk
=================================================================================
Disk Space MUST be in GB/TB - Do not attempt to add decimals in space settings,
Example - Good: 711GB OR 2TB, Example - Bad: 711.5GB OR 2.5TB
=================================================================================

Username: mantax
Quota size for user: (EX: 500GB): 
867GB
setquota: Cannot open quotafile //aquota.user: No such file or directory
1531/2000MB	0.00 0.00 0.00 1/186 2224
[2172:2135 0:58] 03:19:26 Thu Jan 12 [[email protected]] ~ 
(1:58)#

So i restarted again the VPS but again the DISK Status is not working. WHat confuses me also is that since i did that box uninstall quotas command i see in the login shell the time??? and something about 1531/2000MB. Before doing the box uninstall quotas command i think i was seeing the hostname of the server which is mantax i think.

Thanks for the support!!!

George


#11

This is a feature of linux, nothing to be confused about. It’s called reserved file system. What this does is the Linux OS reserves 5% of your total disk space. This 5% is reserved for the file system itself and protects you from filling up your HDD to 100% and thus locking you out of your system entirely.

Quotas will have nothing to do with hostnames as it only sets up the appropriate fields in the fstab.

Try this:

box remove quotas <- this is to ensure that your quotas are removed.

Next, type fix-disk_widget_root and then type service apache2 restart

To see the changes you may also have to clear your browser cache. If the problem persists, please feel free to shoot me a PM and we’ll take a look and see what could be the problem. :slight_smile:


#12

I tried above steps but again it doesnt worked… this is the output of all three commands:

(1:63)# box remove quotas
Package quotas not installed
1527/2000MB	0.00 0.03 0.00 1/183 7763
[7592:7527 0:63] 07:28:16 Thu Jan 12 [[email protected]] ~ 
(1:63)# fix-disk_widget_root
1527/2000MB	0.00 0.03 0.00 1/183 7763
[7592:7527 0:64] 07:28:23 Thu Jan 12 [[email protected]] ~ 
(1:64)# service apache2 restart
1527/2000MB	0.00 0.03 0.00 1/183 7763
[7592:7527 0:65] 07:28:33 Thu Jan 12 [[email protected]] ~ 

What i dont understand is why i dont see anymore my hostname. I see those strange values 1527/2000MB & [7592:7527 0:65]. What do they mean? i was used to see for example my hostname etc there when i used the terminal.

Update: I see the strange above values only when i login via ssh Terminal. I use the Terminal App from my Mac. But when i login with my user that was created i see the hostname like:

[[email protected]]:(0b)~$

Thanks for the support

George


#13

Those values are a measure of your systems current memory averages in increments of 5/10/15 minutes. You can type prompt_OFF to see your hostname. This is a custom ~/.bashrc file that has colorful prompts. In fact, it’s quite clear upon login:

To continue figuring out why your widget is blank, can you provide me the return of the following commands:

uname -a and lsblk


#14

So i executed both commands. First i typed:

uname -a

I got as return the following:

(1:68)# uname -a
Linux mantax 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
1472/2000MB	0.01 0.01 0.00 1/186 16639
[16613:16472 0:69] 11:11:47 Thu Jan 12 [[email protected]] ~ 
(1:69)# 

Then i typed the second command that i was told:

lsblk

I got the following:

(1:69)# lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sr0     11:0    1  1024M  0 rom  
vda    253:0    0   931G  0 disk 
├─vda1 253:1    0 930.5G  0 part /
└─vda2 253:2    0   512M  0 part [SWAP]
1472/2000MB	0.01 0.01 0.00 1/186 16639
[16613:16472 0:70] 11:12:36 Thu Jan 12 [[email protected]] ~ 
(1:70)# 

So still not working the Disk Status… strange…

Thanks for the great support!

George


#15

Can you now type box upgrade then type service apache2 restart.

From this view I see no reason why your widget wouldn’t be working… unless you are caching old data via your browser.


#16

Again not working. For the first command i got a lot of output and an error at the end. When i executed box upgrade at the last line (it was many lines of code) i got the following:

sudo: unable to resolve host mantax

I also restarted apache with the second command. I then went into Chrome which i use as a browser and cleared EVERYTHING from the beginning of the time… everything… passwords, images … everything in the cache is gone. Nothing Disk space is not showwing any number. It says only:

Free: GB
Used: GB
Size: GB

and below of that it says:

You have used NaN% of your total disk space

Thanks for the support…

George


#17

also this would have no impact on the disk widget
this is due to you changed host name after install
you will need to change hostname in the file

nano /etc/hosts

should look something like this with masters-downloader being mantax


#18

My /etc/hosts is as follows:

# Generated by SolusVM
127.0.0.1       localhost localhost.localdomain
::1     localhost localhost.localdomain
95.211.249.114  mantax.lwvps2

As i said. This VPS is a clean fresh Ubuntu 16.04 LTS installation . I did a complete apt-get update & upgrade etc… and then i installed ONLY Quickbox on it.

Should i edit my /etc/hosts file ???

Thanks for the support!!!

George


#19

i would edit it.


#20

Will you please PM me your dashboard IP and username/password? The only way to really confirm this is if someone else can look into this. We’re just going to go around and around without something more hands-on.


#21

Resolved via PM :smiley: