Deluge Wont Start

deluge
ubuntu

#1

I have my QB box in a vmware VM. I moved it from one PC to another, and also changed the IP. Upon moving it some stuff did not work, in particular Deluge was not downloading anything and was showing an error status with the trackers. Today I tried to solve it, one of the things I did was “box remove deluge” and then I tried “box install deluge” and the install gave me the following errors and deluge is not accessible.

# box install deluge
Installing deluge
Traceback (most recent call last):
  File "/etc/QuickBox/packages/system/deluge.Userpass.py", line 13, in <module>
    salt = sys.argv[2]
IndexError: list index out of range
mkdir: cannot create directory ‘/home/syssu/dwatch’: File exists

#2

I figured it out. Whatever that error was it had something to do with my user password. Deluge was installing but for whatever reason the port that was used to access it was blocked, where previously it was not. So I added it to the firewall so it was not blocked and then I could not get into deluge with the default deluge password or my user password so I ran the box changeUserpass and then from there everything worked


#3

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.