Deluge not installing properly

deluge

#1

Hey there, I have setup 4 different servers over the past couple weeks and none of them have had a working Deluge after initial installation of QB. I somehow managed to get one of them to have a working deluge by luck when running upgradeDeluge command several times but other than that, no dice.

I’ve tried installing it as the default version during quickbox installation and also as dev. And after QB installation I have tried upgradeDeluge to repo, stable and dev - none have worked.

Systemctl status is:

[email protected] - Deluge Bittorrent Client Daemon
Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
Active: inactive (dead) (Result: exit-code) since Sun 2017-09-24 02:40:41 CEST; 1min 15s ago
 Process: 5857 ExecStop=/usr/bin/killall -w -s 9 /usr/bin/deluged (code=exited, status=1/FAILURE)
 Process: 5853 ExecStart=/usr/bin/deluged -d (code=exited, status=1/FAILURE)
Main PID: 5853 (code=exited, status=1/FAILURE)

Sep 24 02:40:41 sd-60752 systemd[1]: [email protected]: Unit entered failed state.
Sep 24 02:40:41 sd-60752 systemd[1]: [email protected]: Failed with result 'exit-code'.
Sep 24 02:40:41 sd-60752 systemd[1]: [email protected]: Service hold-off time over, scheduling restart.
Sep 24 02:40:41 sd-60752 systemd[1]: Stopped Deluge Bittorrent Client Daemon.
Sep 24 02:40:41 sd-60752 systemd[1]: [email protected]: Start request repeated too quickly.
Sep 24 02:40:41 sd-60752 systemd[1]: Failed to start Deluge Bittorrent Client Daemon.

I’ve noticed sometimes after restarting the service, it will be active and appear to have a good status for <1 second before changing to inactive.

I’ve tried installing the latest QB on an OVH, Hetzner and Online server and am reaching the same results - Ubuntu 16.04.

I’ve been trying to find any answers to the problem and can confirm there is a USERNAME.info file in root containing the USR:[email protected] line.

Any help is much appreciated. :slight_smile:


#2

I deal with the exact same issue, did you find any resolution in the meantime @Pingu858?


#3

Yup I figured out the fix and posted it but I think QB forums were rolled back.

I believe you just need to run these two commands and then re-install deluge:

sudo pip uninstall pyOpenSSL
sudo pip install pyOpenSSL

Maybe @JMSolo is able to adjust the QB install script to handle this issue. :slight_smile:


#4

I have had this same issue since I ran the updater QB yesterday - Deluge stopped working after running flawlessly for months.

I have searched, uninstalled &- re-installed Deluge several times with no joy!
I see that the issue was resolved by PM but nothing shared… :frowning:

install Deluge after openSSL

QuickBox Deluge status


#5
sudo pip uninstall pyOpenSSL
sudo pip install pyOpenSSL

#6

Thanks, as I said, I saw that too.
I did the whole uninstall Deluge, uninstall pyOpenSSl, install pyOpenSSl, install Deluge thing and No Joy…
Not sure what it did but seems to be an exercise in futility here…
I even upgraded Deluge after the install…

uninstall pyPOpenSSL

install Deluge after openSSL

QuickBox Deluge status


#7

So after fighting to get this fixed, I gave up on Deluge and the Web UI issue. Installed Transmission. Now I can’t log into Transmission or shut it down! After the latest roll out I have to wonder what else is F**** Up!?!?


#8

I am currently reviewing the Transmission issue with login. I think the reverse is off and causing the issue. My development repo doesn’t have the issue, so it’s more than likely a simple fix, I’ll push an update for it soon.

As per your Deluge-Web issue, had you tried to install from the repo (#1 option)?

I haven’t pressed any commits that would affect Deluge, either the daemon, nor web configurations. Have you done any apt -y update and apt -y upgrade?

I’ll dig more into Deluge today as I have time.

Well, hopefully, by kindly reporting these things, I can manage to sort them out. :wink:


#9

I can’t uninstall Transmission either… Yes I did do “apt upgrade -y” too!
A lot of services are off line now. They were all working before…

services


#10

You’ll need to run the updater again, I have built in the Transmission uninstall package and committed the change.

As per your issues with Applications in the red. Could you provide a systemctl status ... of those applications?


With Deluge, I currently cannot reproduce this, but I am going to keep digging into reproducing this issue. Did you install Deluge on the initial setup or after QuickBox was installed?


As per the issue with the Transmission login, this was due to the transmission.conf reverse adding in another auth scope, when Transmission already provides it’s own and is added to /etc/transmission-daemon/settings.json file.

This can be corrected by editing the /etc/apache2/sites-enabled/transmission.conf to read as:

<Location /transmission>
ProxyPass http://localhost:9091/transmission
ProxyPassReverse http://localhost:9091/transmission
Require all granted
</Location>

Followed by an service apache2 reload


#11

I ran the updater & Transmission is working now… thank you.

I installed Deluge with Quickbox and have been using it since the initial install and setup the server last July. The system was built around a fresh install of Ubuntu 16.4 server and Quickbox specifically. Usually managed remotely from a Mint 18 laptop and occasionally at the terminal.

Deluge is configured for full automation script, unpacking moving, etc. SickRage, PlexPy Radarr, Jackett, NZBGet, NZBHydra are all used for Plex with a TV Tuner card for off air recording…

I’ll get the systemctl status’s asap… thank you again!


#12

Well, after several reboots all but Deluge is working again… I ran the QB update again this AM but I don’t understand why it all works!!!

I have not had any luck with anything I have done to make Deluge work short of backing up the config folder and torrents and removing all then re-install…

services


#13

I finally had time to research the cause of the deluged failure…
everything points to /usr/bin/deluged , a path that doesn’t exist!

I ran Find / -name deluge*
only finds the templates etc… Nothing in /etc/bin/deluged… ?/??

So I ran Box / uninstall Deluge…
then Box / Installed Deluge again… still no joy!

I don’t understand how that can happen… Thoughts?


#14

did you try uninstalling and reinstalling pyOpenSSL as @Pingu858 said?
That did the trick for me, but I only had Deluge Web red. Deluged was green.


#15

Yes… see the posted screen shots above. I know that isn’t the problem now, as I have described above. The path is wrong, it points to a non existent source…


#16

I had the opportunity to rebuild the server from scratch. I Built a ProxMox VE with 2 VM’s. Both running QB w/
Plex
PlexPy

on one and

Radarr
NZBGet
NZBHydra
Deluged
Deluge Web
Jackett
Web Console
SickRage
Sonarr

All is working great now!

Please close this issue as resolved, thank you!