Deluge 'BadLoginError: Username does not exist' Help/Assistance Please

deluge

#1

Deluge was originally working. Then I stopped using it. I don’t remember if I removed it or “upgraded” it, but it stopped working.

So I tried BOX (uninstall package) as root. Then reinstall. Get the same error.
Tried upgradeDeluge, tried 1 and 2, same issue.

The status is “green” and the services are running, but for obvious reasons it shows as “bad username”

I tried searching this error as best as I could, and got some deluge-console “connect localhost user pass ; info” command.

This also said that the user/pass should match a file in ./config/deluge. At first it didn’t have a username pass so I added one, same issue.

So now I am here asking for help…anything would be helpful, thanks

EDIT: if it helps, I removed Deluge through “box” and I can still access a webui of deluge at “localip:8112” though it doesn’t connect or anything, everything is blank, I think I need a FULL uninstall (proper) of deluge and everything then reinstall it.

EDIT2: now getting No module named libtorrent


#2

I think the issue was possibly with your password for the user. Try to remove from the dashboard, then add back. Try to login afterwards, if it fails to login, run the command changeUserpass and give the login a go once more.


#3

Can i remove the only user I have then add the user back? I don’t care about settings at this point.


#4

Sure, you could do deleteSeedboxUser and then run createSeedboxUser once more. However, if this is the Primary account you’re talking about, then you could try to run the setup script once more to make necessary adjustments.


#5

Tried removing adding. Tried setup over it. It just caused more issues over issues. Solution was to delete and reinstall =/