Dashboard won't load - HTTP Error 500, but Plex still loads


#1

Error I’m getting from /var/log/apache2/error.log is:

PHP Parse error: syntax error, unexpected ‘;’ in /srv/rutorrent/home/inc/config.php on line 14

I checked /srv/rutorrent/home/inc/config.php but doesn’t seem to be any issues with it, I didn’t modify that file.

I had Quickbox working fine with letsencrypt installed. I did a stupid thing, I changed the hostname of the server and it seems to have broken letsencrypt and caused this error.

Would really hate to start fresh again, can anyone help? I tried re-running ./letsencrypt-auto --apache -d script a few times, but didn’t fix the issue. Maybe I can just start with a fresh apache2 service?

Weird thing is, plex still loads fine if I go directly to the domain.com:32400/web/index.html URL.

Thanks in advance


#2

Hey there @madferret,

You shouldn’t have to start fresh. We’ll try the simplest solution first.

Login to ssh, then enter root by typing sudo su.
Next, type box upgrade.

This will not only replace essential dashboard files, but it will update your installation as well. Hopefully this will resolve what is more than likely a very minor issue. Let me know how it goes.


#3

Thanks! That solved the issue.

Keep up the good work, love the script!