Dashboard partially not working (installing/removing packages, etc)

community
16.04
quickbox
ubuntu
dashboard

#1

Hello there,

I have a Quickbox Community version installation running in Ubuntu 16.04 on a Kimsufi box. It worked flawlessly, but eventually, since I was still using the old repositories, I updated the Quickbox installation following the steps provided to change to the new ones (currently running version 2.5.5).

The problem I’m facing is the following: I can access the Dashboard, but any action on it that uses Javascript - Run Updater, Restart/Enable/Disable services, Clear memory cache, Install/Uninstall packages - the dashboard refreshes, but nothing happens.

Everything else that’s just a simple link works, naturally. Installing/uninstalling, or restarting a service manually (using box command or systemctl) works, only the actions on the dashboard do not - which is kind of annoying in terms of maintenance some times.

For the case of the Run Updater funcionality (or install of a package), the pop up appears but no new content comes up - because no action is taken.

Trying to inspect the Dashboard page (for instance, installing Emby - one package I don’t have installed) - I have this:

jquery.js:8630 GET
https://5.39.93.87/?installpackage-emby=true&_=1544567269591 net::ERR_INVALID_REDIRECT

Not sure if the last part of the URL is correct (after the &), but it looks like some parameter is missing?

Could anyone point me in the right direction (logs, etc.)? Have I missed any step in my upgrade to the new repositories?

I do apologize in advance in case this issue is in another thread, but I tried to look for it without any luck. :frowning:

edit: Already tried the sanity checks - disabling ad-block or script blocker browser extensions, tried another browser, etc.

Thanks!


#2

Hey I see no one has replied to this, and I’m going back through all the missed posts over the last couple of months. Did you ever get this resolved? My other question would be have you tried from another computer as well? Maybe it’s something isolated on that computer? Also what operating system are you running, and is everything updated? Have you done all the recent updated on your QuickBox system as well? Not through the login interface, but logging into the box through SSH (or physically logging in) and running

sudo apt update

(then)

sudo apt dist-upgrade

(then)

sudo apt upgrade

I literally just wiped my box yesterday and moving over to 18.04 and QuickBox Pro, but will try to help the best I can.


#3

Hi,

Many thanks for your answer! And no, I didn’t get it resolved yet.

I tried from other browsers, and from other computers as well (I have Quickbox installed in a seedbox shared with a friend of mine. He also faces the same issue in his computer). I’m running Win10 x64, he runs MacOS, so I guess it’s not an isolated problem from our side.

Quickbox is updated through the ‘updateQuickbox’ command via SSH. Same with the 16.04. Both the dist-upgrade and upgrade were done (and are done regularly, along with updates to Plex, Sonarr, etc.).

I tried to dig around a bit through the Quickbox code in the server, but didn’t find anything that points me in the right direction. :frowning:


#4

hi , i had the same !

does your quota plugin working well ?


#5

No, none of the values show up. The quotas didn’t work well since the beginning (because they weren’t properly configured by me), but actually looking at it now, none of the values in the quota plugin in the dashboard (or the status bar for disk space) show up.

The plugin for the updater also stopped showing the list of latest commits, etc…although that has been more recently than the other issues I described.

image

image