Dashboard issues


#1

Everything was working fine. I then registered a domain and then added Let’s Encrypt. After I did that, I cannot get to the dashboard, it directs me to my Apache default page. I also just keep getting errors with Let’s Encrypt. Very frustrating. I guess I will reinstall the whole thing again. It is fine however until I use Let’s Encrypt. I scoured the forums for a similar issue, but have yet to find one.


#2

How did you install LetsEncrypt?


#3

This way: https://quickbox.io/wiki/install-lets-encrypt-on-your-seedbox/

I also used mydomain.blah and then www.mydomain.blah in that one line. Perhaps that is it. I just tried to reinstall it, and now it’s broken.

It can never locate that file on the last step, so I created an empty file. It was still working OK as far as the cert. But still no dashboard access.

This last time I reran the install, I used another name instead off “www” now it is broken and certs are not working.

It may be quicker to start again, but I get the same errors with Let’s Encrypt on BOTH Dedi Boxes running Ubuntu 16.0.4.


#4

Did you remember to execute the last command?
sed -i "s|DocumentRoot /var/www/html|DocumentRoot /srv/rutorrent/home/|g" /etc/apache2/sites-enabled/000-default-le-ssl.conf && service apache2 restart

Your issues is the common mistake forgetting the last command


#5

Yes, that gives me an error that it cannot locate 000-default-le-ssl.conf. It won’t place that in and I choose that config when installing.


#6

Then you didn’t follow the wiki properly. hate to be so direct, but with over a bakers dozen installs daily on our DNS with that Wiki and no issues, you’ve more than likely submitted the error. We also (as has been announced repeatedly) have a function called box install letsencrypt that does everything for you.


#7

I know that. I actually resolved the issue. The reason it was not creating the file was due to the fact I was placing in xx.net and then xx.xxx.net in the config for the domain, it did not like that. Once I changed that, all is smooth. My fault. It was a DNS issue.

Thanks for your help.


#8