Dashboard broken after update from shell?

resolved

#1

Hi,

I cant acess my dashboard.
It is always asking for a password, but cant acess it.
I can acess sonarr, radarr, plexpy etc with the user and password with no problems, but not the dashboard.

This all happened when i tried to do a box upgrade from the shell

Can anyone please help ?

(1:502)# uname -a
Linux 4.4.0-79-generic #100-Ubuntu SMP Wed May 17 19:58:14 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

(1:503)# whoami
root

(1:501)# box upgrade
Updating QuickBox local repository
Upgrading QuickBox … This may take a moment
cat: /srv/rutorrent/home/db/master.txt: No such file or directory
/etc/QuickBox/packages/system/updateQuickBox: line 52: /srv/rutorrent/home/db/output.log: No such file or directory
HEAD is now at 06eae5e FIX: timestamps on CPU Status widget were delayed - now synced
/etc/QuickBox/packages/system/updateQuickBox: line 54: /srv/rutorrent/home/db/output.log: No such file or directory
/etc/QuickBox/packages/system/updateQuickBox: line 453: /srv/rutorrent/home/db/output.log: No such file or directory

/etc/QuickBox/packages/system/updateQuickBox: line 454: /srv/rutorrent/home/db/output.log: No such file or directory

/etc/QuickBox/packages/system/updateQuickBox: line 455: /srv/rutorrent/home/db/output.log: No such file or directory

/etc/QuickBox/packages/system/updateQuickBox: line 456: /srv/rutorrent/home/db/output.log: No such file or directory
sending incremental file list

/etc/QuickBox/packages/system/updateQuickBox: line 457: /srv/rutorrent/home/db/output.log: No such file or directory

/etc/QuickBox/packages/system/updateQuickBox: line 458: /srv/rutorrent/home/db/output.log: No such file or directory

/etc/QuickBox/packages/system/updateQuickBox: line 460: /srv/rutorrent/home/db/output.log: No such file or directory
sending incremental file list
conf/
css/
images/
js/
lang/
php/
share/

/etc/QuickBox/packages/system/updateQuickBox: line 461: /srv/rutorrent/home/db/output.log: No such file or directory
sending incremental file list
chunks/
chunks/lang/
sending incremental file list
stream/
stream/lang/
sending incremental file list
feeds/
feeds/lang/
sending incremental file list
rutracker_check/
rutracker_check/lang/
rutracker_check/trackers/



widgets/vnstat.php
4,782 100% 49.16kB/s 0:00:00 (xfr#369, to-chk=0/429)

Already on 'master’
Your branch is up-to-date with ‘origin/master’.
Already up-to-date.

cat: /srv/rutorrent/home/db/master.txt: No such file or directory

/etc/sudoers: syntax error near line 26 <<<
sudo: parse error in /etc/sudoers near line 26
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

please HELP! :frowning:


#2

What version of QuickBox are you on?

Also, can you do touch /srv/rutorrent/home/db/output.log and then do chown -R USERNAME:USERNAME /srv/rutorrent/home <== replace USERNAME with your master username. Then try the update with box upgrade.

You will additionally need to create the master.txt file with just your master username in it. Not sure why you have all these files missing, as the only way for them to vanish is if they are removed manually. They are required by the dashboard for proper function and are never touched by an update… as the update needs them.


#3

Hi,
Thanks for the fast reply.

“You are running QuickBox v2.5.1”

i can’t understand why this happened, but it is now fixed.

I did everything you said and it is working now!

Much appreciated!!


#4

Hi,

A quick update…

Your fix resolves the issue, but after a few minutes/hours it reverts back to the problem… how is this possible?

now it wont ask for authentication, just shows the blank page with the directory content…

https://i.imgur.com/VDdpE5i.jpg


#5

Hmm, that’s incredibly unusual. Did you perform any other sort of actions on your server? It would never just revert back to a broken state. If you can provide some additional details as to what steps you may had taken, I can help you find a solution. Otherwise, you’d need to back up your sessions folder as well as any settings and run the installer once more. Once I get back at a computer and not mobile, I can request login details to your server and check this out myself. Something clearly isn’t adding up.


#6

Hi,

I do update the server regularly, with apt-get, and i think this is happening since i upgraded the GitHub repo and did a box upgrade…

I don’t really know what’s going on, i guess i can run the installer again, or you can check things if you have the time, that would be great!

i don’t really know what caused this behavior, everything else seems to be working fine except the dashboard…

Do tell if you want the login details.

Thanks for all the help.


#7

Resolved via PM