Custom domain issue



Hi there !

Today I changed all working from my server

Now to navigate, I have 3 links:
1st (rutorrent) is on: https://rutorrent.domain
2nd (Emby) is on: https://emby.domain
3st (index) is stuck on apache error page or error 403 instead of https://domain

Do you have any tips to correct this problem?

I can send my .conf files on the site-available directory :wink:

Thanks in advance.


I dont understand. Have you bought those domains?


Yes, i bought these domains on namecheap (i’ve masked the real domain on my previous message)


I am not entirely certain on what you are trying to achieve. Are these 3 separate servers with QuickBox installed and you would like their A Records to point at the domain?

Or is this a matter of having 3 separate parts of QuickBox on 3 separate domains?


@JMSolo, it sounds like that :smiley:


Personally…too much of a PITA.

You’d need to mess with virtual hosts and aliases, etc to get this to work.

Ala take out the alias that goes to /rutorrent and make it the root of the virtual host that has the server name for rutorrent.domain.

I see this as becoming too customized and then patching breaks.


Sorry for my explications, i don’t use translators lol


Typically after installation we got 2 links : http://Server-IP (for the dashboard) and http://Server_IP/rutorrent (for rutorrent).

I’ve make the A Records from my domain panel and the DNS are responding fine.

I managed that http://Server-IP/rutorrent become but i can’t manage that http://Server-IP become

Note “” is just an example.


[quote=“tomcdj71, post:7, topic:480”]
I managed that http://Server-IP/rutorrent become [/quote]

You can’t do that with an A record.

you can do:
Server-IP ->


Yes, sorry, i managed it with the apache vhost


isnt your other issue just a DNS issue? you need an A record that points from>IP ?
No subdomain at all?


It isn’t DNS issue, it’s vhost issue.
I can ping my subdomains and the DNS responder looks fine


OK all you need is a domain for the main server so it would be like replacing your address with your domain you do not need to worry about anything after ip address so anything like rutorrent will be included in domain without anything being added. I think this is the info that would be most helpful but, i also have to agree with @RXWatcher this is not considered support for QuickBox this would be more support for domains which is not part of the script it’s extra and would be considered a custom option that we charge for. its one of the things included in the whitelable installs. (i think)

note you only need one domain name for the one server.

@JMSolo let me know if this is out of line i am not sure i am being clear or not?


@dtech Ok, i’ll check tonight and if i can’t find the solution, i’ll give up and i’ll go back to the initial configuration :wink:


This is correct. Anyone willing to help however can feel free if @tomcdj71 is wanting to take their ideas in working order. I am currently working on the publishing of 2.4 to public release, so with that said I cannot offer support on this issue.


@JMSolo No problem, you help me a lot the last time, Quickbox updates is more important than this problem :wink: