Couchpotato redirect to Dashboard

couchpotato

#1

Hi,

First thank your for that amazing script “Quickbox” the installation was super easy !

But, I’m having a trouble with Couchpotato, after installing it, I can’t access to it, il always redirect me on the dashboard changing the URL to

https://MY_IP/#couchpotato

And https://MY_IP:5050/couchpotato isn’t working.

I’v tried to delete it and install it again but, i’m always facing with the same trouble !

Any idea ?


#2

try http://MY_IP:5050/couchpotato


#3

Same thing.


#4

I wanted to bump on this post to say I face the same problem.

Accessing https://myip/couchpotato redirects to https://myip/#couchpotato. I’ve tried http://myip/couchpotato to no avail.

Reinstalling the package is not fixing the problem.

Apache couchpotato.conf is present and reads :

<Location /couchpotato>
ProxyPass http://localhost:5050/couchpotato
ProxyPassReverse http://localhost:5050/couchpotato
AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd'
Require user USERNAME
</Location>    

service memcached restart
service apache2 restart

did not help.

Thank you for your help on this issue !


#5

Hello @floppy and @KRG-23,

Did you install LetsEncrypt SSL certificates ? On which OS did you install QuickBox ?

Could you restart Apache2 with sudo service apache2 restart and try again to connect to :

http://YourServerIP/couchpotato ?

I installed it few minutes ago on Ubuntu 16.04 without any issue.


#6

Hello, I did not install LetsEncrypt SSL certificates. Is it mendatory ? I’ve noticed a howto in the Wiki.

I run QuickBox on
servername:/etc/apache2/sites-enabled# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

I’ve already restarted apache2 a couple of times after Couchpotato install.

servername:/etc/apache2/sites-enabled# uname -a
Linux bt 4.4.0-59-generic #80-Ubuntu SMP Fri Jan 6 17:47:47 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

#7

Did you install Couchpotato form the web UI or from SSH ? (if with SSH, from which account?)


#8

I’ve installed it from the Dashboard


#9

Okay, please execute :

  • if you don’t already set a new password for the root account : sudo passwd root
  • sudo su
  • box remove couchpotato
  • box install couchpotato
  • Try again to connect to http://YourServerIP/couchpotato

#10

FYI, my root account is working since early Quickbox installation

servername:/etc/apache2/sites-enabled# box remove couchpotato Removing couchpotato servername:/etc/apache2/sites-enabled# box install couchpotato Package couchpotatobox not found Package install not found Installing couchpotato servername:/etc/apache2/sites-enabled#

It’s not working: https://myip/#couchpotato

Are there logs where I can track what happened with the missing package installation ?


#11

This seems to be a typing error?


#12

Unfortunately not, I’ve copied&pasted the console output


#13

Really strange… I searched “CouchpotatoBox” into all QB files, it’s nowhere.

Maybe a display bug from the console or during your copy/paste (because the “package install not found” may be the return from the Box script which is looking for the package “package” and not Couchpotato)

Could you try again box install couchpotato (please type it manually)


#14

Ok, I’ve installed the package manually (lazy me!) and it took a bit of time installing without any error message.

servername:/etc/apache2/sites-enabled# box remove couchpotato
Removing couchpotato
servername:/etc/apache2/sites-enabled# box install couchpotato
Installing couchpotato
servername:/etc/apache2/sites-enabled#           

However, I’m still redirected to Dashboard … https://myip/#couchpotato


#15

Where is this coming from? This isn’t present in any of our package installers either. Just ran this on a customers request and it installed without issue. Have you attempted to modify anything on your install @KRG-23? Also, you said:

What does this mean? What version of QuickBox are you currently on?

I’ve no idea where or why you have a #(pound sign) in your link. This is not added by way of the package installer, nor is it an item on the config for the link to CP.

You can review the installer for the CP package here:

As well as review the link on your dashboard here:
https://lab.quickbox.io/QuickBox/quickbox_dashboard/blob/master/inc/config.php#L291


#16

Hello @JMSolo,
Thank you for peering into my problem here.

Here are the answers:

  1. I did not modify anything, I am not that good at manipulating Linux
  2. This was an answer to @PastaGringo who said if you don't already set a new password for the root account : sudo passwd root
  3. You are running QuickBox v2.4.8 - on myip:0.0 Your BASH version is 4.3

I just wanted to install this package via the Dashboard, nothing more. But I’ve tried on different browsers (IE, Chrome on Windows and Android) and the problem remains.

I’ve faced some problems with the Disk status widget but got them solved by reading these pages. Since it concerned only quota, I doubt it could have interfered with CP.

Here is an exerp of my syslog

Jan 30 14:50:53 myserver systemd[1]: Started ACPI event daemon.
Jan 30 14:50:53 myserver systemd[1]: Stopping [email protected]
Jan 30 14:50:53 myserver systemd[1]: Stopped [email protected]
Jan 30 14:50:54 myserver systemd[1]: Reloading LSB: Apache2 web server.
Jan 30 14:50:54 myserver apache2[29301]:  * Reloading Apache httpd web server apache2
Jan 30 14:50:54 myserver apache2[29301]:  *
Jan 30 14:50:54 myserver systemd[1]: Reloaded LSB: Apache2 web server.
Jan 30 14:51:01 myserver CRON[29406]: (root) CMD (bash /usr/local/bin/quickbox/system/set_interface)
Jan 30 14:51:01 myserver CRON[29405]: (root) CMD (/usr/local/rtm/bin/rtm 25 > /dev/null 2> /dev/null)
Jan 30 14:51:39 myserver systemd[1]: Reloading.
Jan 30 14:51:40 myserver systemd[1]: [/etc/systemd/system/[email protected]:1] Assignment outside of section. Ignoring.
Jan 30 14:51:40 myserver systemd[1]: [/etc/systemd/system/[email protected]:2] Assignment outside of section. Ignoring.
Jan 30 14:51:40 myserver systemd[1]: [/etc/systemd/system/shellinabox.service:3] Unknown lvalue 'Required' in section 'Unit'
Jan 30 14:51:40 myserver systemd[1]: [/lib/systemd/system/plexmediaserver.service:11] Invalid escape sequences in line, correcting: "/bin/sh -c 'LD_LIBRARY_PATH=/usr/lib/plexmediaserver /usr/lib/plexmediaserver/Plex\ 
Media\ Server'"
Jan 30 14:51:40 myserver systemd[1]: Started ACPI event daemon.
Jan 30 14:51:40 myserver systemd[1]: Starting [email protected]
Jan 30 14:51:41 myserver systemd[1]: Started [email protected]
Jan 30 14:51:41 myserver systemd[1]: Stopping [email protected]e.service...
Jan 30 14:52:01 myserver CRON[30703]: (root) CMD (bash /usr/local/bin/quickbox/system/set_interface)
Jan 30 14:52:01 myserver CRON[30702]: (root) CMD (/usr/local/rtm/bin/rtm 25 > /dev/null 2> /dev/null)
Jan 30 14:53:01 myserver CRON[31107]: (root) CMD (/usr/local/rtm/bin/rtm 25 > /dev/null 2> /dev/null)
Jan 30 14:53:01 myserver CRON[31108]: (root) CMD (bash /usr/local/bin/quickbox/system/set_interface)
Jan 30 14:53:12 myserver systemd[1]: [email protected]: State 'stop-sigterm' timed out. Killing.
Jan 30 14:53:12 myserver systemd[1]: Stopped [email protected]
Jan 30 14:53:12 myserver systemd[1]: [email protected]: Unit entered failed state.
Jan 30 14:53:12 myserver systemd[1]: [email protected]: Failed with result 'timeout'.
Jan 30 14:53:12 myserver systemd[1]: Reloading LSB: Apache2 web server.
Jan 30 14:53:12 myserver apache2[31191]:  * Reloading Apache httpd web server apache2
Jan 30 14:53:12 myserver apache2[31191]:  *
Jan 30 14:53:12 myserver systemd[1]: Reloaded LSB: Apache2 web server.
Jan 30 14:53:12 myserver systemd[1]: Starting [email protected]
Jan 30 14:53:13 myserver systemd[1]: Started [email protected]

Hope this helps


#17

Could you shoot me a PM with your server details (ie; login credentials)? I will gladly login and give this a once over to where the problem may be.


#18

@JMSolo,
PM sent, thanks a lot !


#19

Posting the solution here for transparency…

###Solution
I noticed (as it finally occurred to me browsing your install) the redirect back to the dashboard was happening due to the url base within your couchpotato settings was empty. I did the following to fix it.

cd /home/$USERNAME/.couchpotato
nano settings.conf

With the settings.conf folder I searched for the url base = field. I changed it to the following url base = /couchpotato.

From here I did a restart of the CouchPotato service with systemctl restart [email protected]$USERNAME.

Voilà, CP is now accessible.


Two issues after fresh installation
Unable to access Couchpotato/Jackett/Plex Py etc from dashboard
Couch Potato from Dashboard
#20

Thank you very much for your help! This is working. I can’t log in though but I’ll try to work that out.

EDIT: computer at work is behind a PROXY, it’s working from my smartphone and my home computer, this is JUST fine! Kuddos to you!