Couch Potato from Dashboard

couchpotato
dashboard

#1

Hi Guys,

I’m not sure why this is happening:

When I click the “Couch Potato” link in Dashboard, it forwards me to
https://mysub.domain.net/login/?next=%2Fcouchpotato

I then get the 404 error:


Not Found

The requested URL /login/ was not found on this server.

Apache/2.4.18 (Ubuntu) Server at mysub.domain.net Port 443


If I hit couchpotato manually at port 5050 I can access with no issues, but I only have that open to VPN traffic. I thought apache would have done some weird proxy voodoo to hide it behind /couchpotato

Am I misunderstanding how it works?


#2

Not quite sure why you’d encounter this issue, I can see it redirecting to the login of CouchPotato without issue. Have you tried to refresh your browser cache or perhaps tested it with another browser.

Also, double check real quick that you have the couchpotato.conf file located at /etc/apache2/sites-enabled

The contents should read as:

<Location /couchpotato>
ProxyPass http://localhost:5050/couchpotato
ProxyPassReverse http://localhost:5050/couchpotato
AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd'
Require user USERNAME
</Location>

#3

Yup, .conf file is where it’s meant to be:

> <Location /couchpotato>
> ProxyPass http://localhost:5050/couchpotato
> ProxyPassReverse http://localhost:5050/couchpotato
> AuthType Digest
> AuthName "rutorrent"
> AuthUserFile '/etc/htpasswd'
> Require user gareth
> </Location>

Incase it’s relevant, the permissions are:
> -rw-r--r-- 1 www-data www-data 224 Oct 12 19:15 couchpotato.conf


#4

Have you tried clearing your browser cache and/or testing from another browser?


#5

yup,

tried clearing cache
another browser on the same device
private browsing for luls
and my phone.

all doing the same thing.

It’s not the end of the world - I can use the :5050 port - more just curious why it doesn’t behave like sick rage.


#6

Try to run the following and connect back to the link. It should honestly have no issues whatsoever as it’s a simple proxy forward… and maybe apache didn’t get a restart after the install and therefore it’s not picking up the config file?

service memcached restart
service apache2 restart

#7

That didn’t resolve either.

After trying to re-create my steps I managed to resolve by removing couchpotato and reinstalling via the dashboard.

That’s a few times now you’ve been quick to reply. I genuinely appreciate you taking the time to help!

Vakyre14


#8

Glad you got it working. I would had advised the reinstall, but that is always a last resort… depending on settings and config. :slight_smile:


#9

I followed your steps here, the file seems to be configured correctly.
I believe my problem was similar to OP’s. When I click on couchpotato inside of the (wonderful^^) dashboard,
it opens a new tab, which then lags a bit and then just becomes a duplicate off the dashboard page.
[url becoming: https://163.172.217.216/#couchpotato]

When I run checkinstall on couchpotato I get a certain error:

When I try to remove it in the web ssh.


#10

The proper command to use as root is box install couchpotato and to remove box remove couchpotato

Also, see my solution here: