Console is not working. it does not even open


#1

I am trying to access to the console but it is not opening any ideas?


#2

What does typing this as root show?

systemctl status shellinabox

#3

it says this;

● shellinabox.service - Serve a login-terminal over http on port 4224.
Loaded: loaded (/etc/systemd/system/shellinabox.service; enabled; vendor preset: enabled)
Active: active (running) since Çrş 2016-08-31 23:21:46 EEST; 1 day 21h ago
Main PID: 2743 (shellinaboxd)
CGroup: /system.slice/shellinabox.service
├─2743 /usr/bin/shellinaboxd -q --disable-ssl -background=/var/run/shellinaboxd.pid -c /var/lib/shellinabox -p 4224 -u shellinabox -g shellinabox --user-css Normal:+/etc/shellinabox/options-enabled/00_QuickConsole.css
└─2744 /usr/bin/shellinaboxd -q --disable-ssl -background=/var/run/shellinaboxd.pid -c /var/lib/shellinabox -p 4224 -u shellinabox -g shellinabox --user-css Normal:+/etc/shellinabox/options-enabled/00_QuickConsole.css

Eyl 02 20:27:31 alp systemd[1]: [/etc/systemd/system/shellinabox.service:3] Unknown lvalue ‘Required’ in section 'Unit’
Eyl 02 20:27:32 alp systemd[1]: [/etc/systemd/system/shellinabox.service:3] Unknown lvalue ‘Required’ in section 'Unit’
Eyl 02 20:28:09 alp systemd[1]: [/etc/systemd/system/shellinabox.service:3] Unknown lvalue ‘Required’ in section 'Unit’
Eyl 02 20:28:09 alp systemd[1]: [/etc/systemd/system/shellinabox.service:3] Unknown lvalue ‘Required’ in section 'Unit’
Eyl 02 20:28:09 alp systemd[1]: [/etc/systemd/system/shellinabox.service:3] Unknown lvalue ‘Required’ in section 'Unit’
Eyl 02 20:28:13 alp systemd[1]: [/etc/systemd/system/shellinabox.service:3] Unknown lvalue ‘Required’ in section 'Unit’
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.
~
~


#4

Hard to say as according to the status you just posted, it is active and running. Are you referring to the Web Console on your dashboard or the ssh client such as putty?


#5

i meant web console on my dashboard :slight_smile:


#6

…and you cannot access this by the link on your dashboard?

Have you modified any apache configurations?


#7

I can not access it through the dashboard.

And No I haven’t modified anything. I just changed the location of the server (Turkey to Canada). :frowning:


#8

That’s odd as this is the first I have heard of this and cannot reproduce on a new install.

Can you tell me what files you have when you do - feel free to sensor username specific things:

la -l /etc/apache2/sites-enabled

#9

no need to sensor :slight_smile:

-rw-r–r-- 1 root root 1,1K Eyl 1 00:57 aliases-seedbox.conf
-rw-r–r-- 1 root root 1,3K Tem 28 06:09 aliases-seedbox.conf.orig
-rw-r–r-- 1 root root 419 Tem 28 06:09 alp.console.conf
-rw-r–r-- 1 root root 1,6K Tem 19 01:52 default-ssl.conf
-rw-r–r-- 1 root root 116 Tem 19 01:52 fileshare.conf
-rw-r–r-- 1 www-data www-data 545 Eyl 1 21:05 plex.conf


#10

Does the inside of your alp.console.conf look something to this effect?

LoadModule proxy_module /usr/lib/apache2/modules/mod_proxy.so
LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so

ProxyRequests Off
<Proxy *>
	AddDefaultCharset Off
	Order deny,allow
	Allow from all
	AuthType Digest
	AuthName "rutorrent"
	AuthUserFile '/etc/htpasswd'
	Require valid-user
</Proxy>
ProxyPass /USERNAME.console http://SERVERIP:4224
ProxyPassReverse /USERNAME.console http://SERVERIP:4224

#11

how can i look inside of that file?


#12

To Edit inside the file:

nano /etc/apache2/sites-enabled/alp.console.conf

To just read the contents of the file:

cat /etc/apache2/sites-enabled/alp.console.conf

#13

I opened that file and changed the ip address that was written there because it was wrong (I changed the static ip of the server and in the conf file it was not changed.)

Now I can access the console through http://SERVERIP:4224. But can’t not reach it through dashboard = http://SERVERIP/user.console


#14

After you modify that file do service apache2 restart


#15

it worked!! Thank you man!


#16

No problem! Glad you got it all set. :slight_smile:


#17

Hi! You’re awesome, this fixed it for me too.

I started running VPN as client at boot and the console conf file was set to my internal VPN IP for tun0 (10.0.1.6 or something), not my local network IP. I changed it back to my LAN IP and web console works again.

Strange that it kicked in that change to my conf randomly but worked for a long time before that.