Connect to Sonarr/Couchpotato, from Ombi running on different machine


#1

I installed quickbox on my VPS and it’s working quite well. However, I got a relatively cheap one with only 1 GB of memory. Especially Ombi, often makes it run out of memory.

I intend to run Ombi on a different server to offload pressure on the VPS. From that server I’m able to connect to Plex on the VPS. I also want to connect it to Couchpotato and Sonarr, but don’t manage to get those connected.

I also installed let’s encrypt on the VPS, which might potentially be a reason to connect it differently.

Should I be able to connect via IP of the VPS, port 8989, SSL enabled?


#2

I’m a little but further finding where the issue is:
Have to login via port 443, with urlbase /sonarr

But now I hit the generic username/password login for the dashboard (also working for sonarr and couchpotato)

On my laptop it gives a true when I use it on chrome (already logged in on the dashboard)
https://servername.com/couchpotato/api/186b46683899dhhsg76fe0f8d9cc0/app.available/

But when I use it in safari, it request the generic username/password of the server. That’s probably also the one that the other server hits when Ombi wants to connect to the VPS.

Is there a way to move sonarr and couchpotato from behind the dashboard username/password (and using their own login method). Any risks attached?

Btw: saltrocking/reebok is both me


#3

Why different accounts? lol.

Yes, you can remove the global QB password from Sonarr/Couchpotato. I don’t believe it’s a security risk, so long as you set passwords via each applications native method.

From SSH:
Get into sudo

sudo -i

Begin editing the config file:

nano /etc/apache2/sites-enabled/sonarr.conf

Remove:

AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd'
Require user ${username}

Ctrl X + Ctrl Y + Enter

Repeat for CP:

nano /etc/apache2/sites-enabled/couchpotato.conf

Remove:

AuthType Digest
AuthName "rutorrent"
AuthUserFile '/etc/htpasswd'
Require user ${MASTER}

Ctrl X + Ctrl Y + Enter

Restart Apache:

systemctl restart apache2

Exit sudo:

exit