Connect Sonarr to rTorrent



Firstly thank you so much for this project. This is my first time using a dedi and quickbox so far has made it a real breeze.
I say so far as I am having issues connecting sonarr to rtorrent.

So I have:

Host: Localhost
port: 80

Username: QBUNAME
Password: Checked numerous times to be correct

For the URL path i have tried the below configurations:

QBUNAME/RPC - Result when browsing in chrome to this folder: “Forbidden. You dont have permission to access QBUNAME/RPC on this server.”

QBUNAME/RPC2 - Result when browsing in chrome to this folder: “Forbidden. You dont have permission to access UNAME/RPC2 on this server.”

/rutorrent/plugins/httprpc/action.php - just shows “false” when browsing to this page.

/rutorrent/plugins/rpc/rpc.php - Shows “Link to XMLRPC failed, May be rTorrent is down?” Although it isnt, its working fine.

Could anyone help?

Thanks in advance.


Are your settings like the following on this thread? I assume so. Maybe try adding in your server IP instead of localhost? I’ll try this on a fresh setup shortly and see what I can find.



Thanks for getting back to me.

Yes I have tried the settings on that thread and they dont work. What I think maybe the issue is that when I browse to QBUNAME/RPC2 in chrome I get error forbidden You don’t have permission to access /QBUNAME/rpc2 on this server.

Looking in my SRV folder there is no folder for my username, should there be?

I have also tried with local host and actual IP and nothing has worked.


Sorry to waste time, but I have adjusted the settings and got it to work.
I have literally been trying all day.

Settings should be:

Hostname : localhost
port: 443

URL Path: /rutorrent/plugins/httprpc/action.php

This has now tested successfully.

Sorry to waste your time.


Interesting, glad SSL works out for you. I just tested with the default port 80 and no SSL without issue connecting. We’ll mark this up as another option in the Wiki Doc release here soon.