Cloudbit VPS feedback

thirdparty
feedback

#1

Hi everybody!

I’m sure you’ve all seen the posts about the CloudBit VPS Machines:

I thought it might be nice to share a little feedback about the service. I’m currently using a Scaleway C1 as my public torrent box to compare with.

Pros:

  • Simple to set up (like 3 clicks)
  • Anonymous purchase process with bitcoin if preferred
  • Incredibly competitive pricing (vs Online.net’s Scaleway boxes)
  • Unlimited Gigabit, no worries about going over monthly allowances

Cons:

  • Limited storage options (I know this is being worked on)
  • VPS so resources are shared (compared to the Scaleway / Online.net options) - noisy neighbours may cause trouble.
  • Still kinda beta buggy (I’m sure this will resolve over the next few weeks)

Feedback regarding the image:

  • Default username / password of seedbox/seedbox, while it’s easy to set up - It’d be nice to have a scripted command to change the defaults - e.g. typing quickpasswd and a bash prompt asking for the new default user / password ( not sure how easy that is to do after the initial setup)
  • a quick IP lookup during startup in rc.local to update the IP address in /etc/profile would be good for new users.
  • I tested the built in lets encrypt installer using box - worked flawlessly
  • Downloaded Rogue one at a solid 100MB/s (megabytes) can’t really complain about performance.
  • Storage has increased from 25GB to 50GB - with those speeds to took minutes to fill up 25 gb

Over all opinion:

For me, I don’t need a lot of storage - my VPS is primarily a VPN server with deluge running for the occasional public torrent.
The gigabit unlimited data is the main selling point for me. Good luck to CloudVPS, I’ll probably be switching my Scaleway box over sometime later this month.

Update

For those interested - speeds transferring files from Roubais #1 to the UK maxed out the 200mbit connection:

Transferring it directly from Roubais #1 to my Hetzner box pretty much maxed out the upload:

As @JMSolo said, it’d be interesting to see how things go as the slots fill up - for now I’m very happy.


#2

Interesting. Real cool. I may have to check them.out. How is streaming like from within Plex? Transcoding? Thanks for the write up!


#3

Since their locations are primarily France and Canada, it seems that for myself (being located in the US), is having a good run of streaming at 720 without issue… whereas my box in France can hit some heavy lag every now and again (usually peek hours) which is purely network related.

I have a beefy Online.net dedi and this is keeping it’s paces with that particular server. However, sharing the libraries with about 8 family/friends may become the pitfall. That’s understandable due to the nature of this being a tiny VPS compared to a big 24 threaded dedicated. I have had 3 people so far connect and stream randomly and so far it’s not a hiccup in sight. Now, once there are other neighbors (users like myself) sharing libraries and streaming… that’s yet to be seen.

###Update.
My test box gets crippled with rclone mount - (sort of expected)


#4

Thanks for the write-up–super helpful!


#5

rather than using rclone, cloud you not SSHFS to the other server using rclone?


#6

It was actually Plex settings that were causing this. I’m testing it with rclone filebot automation to ACD. When your settings are at ‘Make my CPU hurt’, I guess it has a tendency to do just that. :laughing:


#7

out of curiosity, did you use the pre-built image or did you just run the script on the ubuntu image?


#8

Hi all

Network wise I’m really very happy. Machines are also easy to spin.

From time to time, I have load jumping to the sky and the server becomes unusable, for simple operations, I can reproduce a load of 15 by building tree during apt-update ! I cannot transcode with plex.

I’ve tried this on the BigData server and on Roubaix 2


#9

The pre-built package. I did however need to change it to the new QuickBox/QB repo after install as it’s making use of the QuickBox/QuickBox (submodule) repo that we are not updating anymore due to the changes about to happen with v3.


#10

Hi, I have tried to do this on Ubuntu 16.04 and when I reboot there server I can never connect again. If I dont reboot after install it works. I think it has to do with the private/public IP…Any suggestions?