Changing rTorrent Port Range/Ports

rtorrent
configuration
rutorrent

#1

I need to change the ports that rTorrent uses (one of the trackers wants our ports to be within a certain range).

So I changed it in .rtorrent.rc

network.port_random.set = yes
network.port_range.set = 55000-56000
network.scgi.open_port = localhost:55000

I then updated the apache conf file (sites-enabled/default-ssl.conf) and updated all the instances where the port was used:

SCGIMount /whiteazn 127.0.0.1:55000

I restarted rtorrent service, then restarted apache.

In the QB Panel, it shows it up and running.

But when I go to rTorrent, it says it cannot connect to the list of torrents, and in the log, it says to check $scgi_port and $scgi_host in config.php and scgi in rtorrent settings.

I checked /srv/rutorrent/conf/config.php
but the scgi port there was at the default 5000, same as in your git repo ( https://lab.quickbox.io/QuickBox/quickbox_rutorrent/blob/master/conf/config.php )

Is there a file I am missing here that needs to be changed and updated?


#2

You will need to adjust it within the following location to make your changes complete:

/srv/rutorrent/conf/users/USERNAME/config.php

You’ll note the scgi port at line #18 within that file.


#3

Thank you, that fixed it.