Can't access Plex

plex

#1

Hi,

I installed QuickBox on my server.
No problem with the installation, rTorrent is working.

I clicked to install Plex via the Quickbox Dashboard. It worked.

But then Plex’s icon is red,
and doing an SSH tunnel via Putty and trying to access Plex via http://localhost:8888/web/
isn’t working… it ask me to enter my login and password but “503 service unavailable”…
and if I try to access via the Dashboard I have “503 Service unavailable” too

Systemtcl -l status plexmediaserver.service shows : https://gyazo.com/56c78ac0d054dc25feb80f62dc983815

I need some help :stuck_out_tongue:

Thanks


#2

try rebooting server maybe.


#3

Not working :frowning:


#4

did you change any settings?


#5

No, like I said I installed QuickBox, then Plex via the Dashboard…


#6

what OS are you using?


#7

Try to uninstall PMS from the Package Management Center in the Dashboard.

After that log into your server through SSH (4747) and

su root
box

Select Plex and intall it.
The shell may be a bit stuck at “Updating system …”.
After a while, maybe the box screen will show up, close it and refresh your dashboard.
Plex icon should be green and the redirection should work too.

You maybe need to set up the SSH tunnel with the port 31400 (I can’t test it at work).


#8

check that ${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR} folder is created? And owned by plex?

Cannot remember the path for it but something like /var/lib/plexmediaserver/Library/Application Support


#9

I’m using Debian 8.


#10

i recommend trying Ubuntu 16.04


#11

I did what you said but Plex icon still red but there was an error : https://gyazo.com/0efcbf243e6f583060f921ec9026718e
(I did not try to set up the SSH Tunnel yet but I guess with the red icon it’ll not work ?)


#12

ls /var/lib/plexmediaserver show nothing… ?


#13

I’ll try with Ubuntu when I can…
I keep you in touch !


#15

ahh that error is because the script dosn´t create the plexuser:

try
uninstall plex
run this command
adduser --quiet --system --shell /bin/bash --home /var/lib/plexmediaserver --group plex

reinstall plex

should fix the problem shown!


#16

the installation tries to create a folder:
Named Application Support

Install had problems starting the service because of a missing folder.
/var/lib/plexmediaserver/Library/Application Support was missing.

so a manual creation of that folder was needed…


#17

Sorry I’m french I don’t understand why the post will be deleted ?

Too late to try it, I tried with Ubuntu and it works !

Thanks for the help !


#18

I get this everytime I reboot my server and try load plex up:

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /web/.

Reason: Error reading from remote server

Any ideas?


#19

The issue was resolved for me by running chown plex:plex /var/lib/plexmediaserver -R and then starting plex with systemctl start plexmediaserver, seems the package doesn’t do that on its own.


#20

This has been addressed in a recent update. You’ll need to ensure that you are on the GitHub repository as we are soon to retire our own GitLab.

The commits can be seen here:
https://github.com/QuickBox/quickbox_packages/commit/9aea20220ee846c325e52d5d465d4890e7d9f5d1

…and here:
https://github.com/QuickBox/quickbox_packages/commit/6c15e1b98252b82a0d802625cfd0701f1b61927f

:mega: Update to the GitHub repo for all future updates.

You can update to the GitHub repo by following the steps listed here: