Cannot update quick box etc


#1

I pressed the update via the run updater and all I got was errors, I logged into root tried to do an
update there and also got errors and updates were not done, I have snap shots of the messages but no idea whats goings on.

via root
http://i.imgur.com/c3tZnTG.png
via run updater
http://i.imgur.com/ajATFk0.png


#2

Have you tried sudo apt-get install -f ?


#3

No I tried… sudo apt update && sudo apt upgrade since my box was tuned here when they had the service I have just been using that one command to update as I did not want to try anything else that might loose settings will give it try thanks


#4

Just so you know:

http://manpages.ubuntu.com/manpages/zesty/en/man8/apt-get.8.html

-f, --fix-broken
Fix; attempt to correct a system with broken dependencies in place.
This option, when used with install/remove, can omit any packages
to permit APT to deduce a likely solution. If packages are
specified, these have to completely correct the problem. The option
is sometimes necessary when running APT for the first time; APT
itself does not allow broken package dependencies to exist on a
system. It is possible that a system’s dependency structure can be
so corrupt as to require manual intervention (which usually means
using dpkg --remove to eliminate some of the offending packages).
Use of this option together with -m may produce an error in some
situations. Configuration Item: APT::Get::Fix-Broken.


#5

Second line when using the QB update

Fatal: Unable to access ´https://lab.quickbox.io…´

You need to upgrade to the latest repo


#6

thanks I will take a look at this as well see how easy it is, I just thought things update themselves, I am a total windows person normally


#7

Not always. We announced it back in feburary.
Follow the posted steps and you should be golden


#8

Thanks I will follow the update for github


#9

Thanks my github problem seems solved I have updated easier than I thought says I am on current build, I have not got anywhere with the other problem looks like it cannot make space for update killed by broken pipe whatever that means, I tried the sudo apt-get install -f command I will look through the other link provided, I only have 26 packages and 12 security updates its been much worse than that.

current error pic via root
http://i.imgur.com/3lM4AWy.png


#10

yeah, upgrading repo is a more important thing than what I’ve suggested :wink:


#11

Hey @baggies666, try the following:

dpkg --configure -a
apt -y autoremove
apt -f install
apt -y update
apt -y upgrade

#12

thanks for the suggestion, as soon as I put the dpkg one in just brought up lots of errors, I carried on but it seems needed 1st one to work.

http://i.imgur.com/EwIfYa4.png


#13

Will you run apt -y autoremove && apt -y autoclean


#14

I get this now

Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies:
linux-image-extra-4.4.0-79-generic : Depends: linux-image-4.4.0-79-generic but it is not installed
linux-image-extra-4.4.0-93-generic : Depends: linux-image-4.4.0-93-generic but it is not installed
linux-image-generic : Depends: linux-image-4.4.0-93-generic but it is not installed
Recommends: thermald but it is not installed
E: Unmet dependencies. Try using -f.


#15

Awesome! Now run the above once more:

dpkg --configure -a
apt -y autoremove
apt -f install
apt -y update
apt -y upgrade

#16

I am still just getting errors somewhere in my setup is corrupt
22.txt (15.4 KB)


#17

Navigate real quick to /etc/apt/sources.list.d/ and remove all but one of those sonarr.list


#18

done just sonarr.list there now


#19

Try the update process once more. There are some keys that need updating as well for additional apt repos.


#20

I am now seeing that message about multiple times so can see why you cleared all the files, not sure why message still showing though

W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list.d/sonarr.list:1 and /etc/apt/sources.list.d/sonarr.list:3
W: Target Packages (main/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list.d/sonarr.list:1 and /etc/apt/sources.list.d/sonarr.list:3
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list.d/sonarr.list:1 and /etc/apt/sources.list.d/sonarr.list:3
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list.d/sonarr.list:1 and /etc/apt/sources.list.d/sonarr.list:3