Cannot install headphones separatly with quickbox

debian8

#1

Hi there

First off amazing job on the script its amazing compared to my Linux noob duct tape approach to things and the problems i did have i was able to resolve with a bit of google hunting now everything inside the script is working fantastically well even brought my sickrage backup over and got it working with the dashboard

however the one app i cant get working is headphones i see on other posts your not a big fan of this so haven’t included it yet so i thought id install it myself ive done this before on Debian 8 with no issue multiple times

here is the problem presented to me

i followed these intrustions like i have before

it goes like normal up until i start the application and receive this message

xdg-open: no method available for opening 'http://localhost:8181

ive tried hunting for a solution myself and posting here is a last resort

if you can help fantastic if not i understand as it is not your work

again thank you for your work its made my dedicated experience look and feel very professional


#2

I’ll try to help you out. I have never used the app but its pretty straight forward.

  1. Plexpy also runs on the same default port as headphones so you need to start it like this:
    python Headphones.py -p 8182
  2. When you start it, you’ll notice that it says:

python Headphones.py -p 8182
13-Nov-2016 10:45:46 - INFO :: MainThread : Checking to see if the database has all tables…
13-Nov-2016 10:45:48 - INFO :: MainThread : Retrieving latest version information from GitHub
13-Nov-2016 10:45:48 - INFO :: MainThread : Headphones is up to date
13-Nov-2016 10:45:48 - INFO :: MainThread : Using forced web server port: 8182
13-Nov-2016 10:45:48 - INFO :: MainThread : Starting Headphones web server on http://localhost:8182/
13-Nov-2016 10:45:49 - INFO :: MainThread : Scheduled background task: Search for Wanted
13-Nov-2016 10:45:49 - INFO :: MainThread : Scheduled background task: Download Scan
13-Nov-2016 10:45:49 - INFO :: MainThread : Scheduled background task: Library Scan
13-Nov-2016 10:45:49 - INFO :: MainThread : Scheduled background task: MusicBrainz Update
13-Nov-2016 10:45:49 - INFO :: MainThread : Scheduled background task: Check GitHub for updates
13-Nov-2016 10:45:49 - INFO :: MainThread : Scheduled background task: Torrent removal check

It’s listening only on localhost so its only accessibly from the machine itself(like using x2go). You need to edit the config.ini and replace the two entries for ‘localhost’ with 0.0.0.0 . This will make it so you can connect to it outside of the machine.

now connect to it via http://server:8182/


#3

i appreciate your input but whenever i try and run the command including the force port command i get the message quoted above so i can’t actually run it i know how to set it up ive done it many times just not with quickbox installed


#4

It’s interesting because I didnt have that issue but I’m running Ubuntu 16.04.

  1. I assume you’re running this as root? and not just sudo?
  2. What version of python are you using? python --version
    The only supported python versions are 2.6 and 2.7.

#5

If you google that error, it looks like its trying to open a web browser but non is defined.

Are you running this on a debian server with a GUI? That would explain it.

When you run this from a GUI, it wants to open up a browser session…that would totally explain your error if you dont have one defined.


#6

thank you very much sir
i do have a gui installed how would i fix the issue


#7

edit the config.ini and change this:
launch_browser = 1
to
launch_browser = 0

I’ll bet that will do it.


#8

sorry dumb question but were would it be located

EDIT

just worked out what you mean trying now


#9

Ive cracked it thanks to you my friend my dedicated server has never been more complete