Cannot connect to my x2go server


#1

Hi

Im using leaseweb dedi + debian8 + xfce. When I try to connect from my win7 x64 desktop I get this popup:


Error

Connection failed.
*** forbidden char/command over SSH: “bash -l -c 'echo “X2GODATABEGIN:b13f68c9-2190-4862-9e2c-8273165d56e9”; export PATH=”/usr/local/bin:/usr/bin:/bin"; export TERM=“dumb”; export HOSTNAME && x2golistsessions; echo “X2GODATAEND:b13f68c9-2190-4862-9e2c-8273165d56e9”;’"
This incident has been reported.


OK

Any suggestions? Thanks.


#2

Are you trying to connect as one of your other users or your master user?

The reason I ask is the ‘forbidden char/command over ssh’. bash, echo and export aren’t in the limited shell command list.

If it’s your master user then it’s probably time to look at some server logs.

If its your other users then edit /etc/lshell.conf and add those commands to the allowed list:

[global]
logpath         : /var/log/lshell/
loglevel        : 2

[default]
allowed         : ['grep','cd','cp','-d','-dmS','git','irssi','ll','ls','-m','mkdir','mv','nano','pwd','-R','rm','rtorrent','rsync','-   S','scp','screen','tar','unrar','unzip','nano','wget']
forbidden       : [';', '&', '|','`','>','<', '$(', '${','sudo','vi','vim','./']
warning_counter : 2
aliases         : {'ls':'ls --color=auto','ll':'ls -l'}
intro           : "== Seedbox Shell ==\nWelcome To Your QuickBox Seedbox Shell\nType '?' to get the list of allowed commands"
home_path       : '/home/%u'
env_path        : ':/usr/local/bin:/usr/sbin'
allowed_cmd_path: ['/home/']
scp             : 1
sftp            : 0
overssh         : ['ls','rsync','scp']

#3

It’s shared dedi, so I would say as other user.


#4

see my edits above :slight_smile:

Maybe edit the ‘overssh’ section too.


#5

@RXWatcher then what to do after add grep ?


#6

Seeing this from a secondary user account on my server as well. Tried adding a bunch of the commands from the error to allowed/overssh, but still get the error.