BTSync Folder Permissions

btsync
ubuntu

#1

Hi,

I’ve completed a fresh install on 16.04. Everything seems to be working fine except for BTSync which doesn’t seem to have any write permissions on any folders. It doesn’t ask for login details either so maybe that’s part of the issue. I’m really new to this stuff so I’ll need specific instructions.

Thanks


Sync from seedbox to home
#2

By default QuickBox has compiled BTSync to make use of more secure directories within a users /home (this may be overkill and is a product of the way I handle business critical data with clients :blush:)

This method ensures that files chances of being deleted or otherwise remain at a minimum.

The folder marked sync_folder is the ordained location for housing files a user may want to process remotely.

Additional to this, the script leaves any of the customization needs you may require solely to you in terms of login credentials. You can set these values as such:


#3

Ok thanks. On that note, is there any way for me to enable SickRage to create files/folders in that directory?


#4
  • Navigate to “Search Settings

  • Go to the tab labeled “Torrent Search” and select “rTorrent” from the dropdown

  • Fill in needed info and select “Browse…” to choose your preferred Download location for files.
    For more info on what those settings should be, this post by @Eikichi may be helpful

  • Now navigate to the /sync_folder in your /home directory and select “OK


#5

Hi J. How can i sync to my rwatch folder or selected folder since only solo user? TQ


#6

nvm. its working for me now. thanks anyway


#7

Sorry to bring this post back to the top but I have just done a clean install of quickbox and btsync (now resilio) does not allow me to select any folder.

Any idea’s?


#8

Have you tried creating a sub-directory under that dir?


#9

You need to set (manually) right permission for that folder. If I remember correctly you need a special permission doing this: chmod -R 4775 /home/anoniemver/Downloads

Doing this your folder will have “drwsrwsr-x” permission.


#10

Hi guys

I also have the problem that Soulplayer illustrates.

I tried you option Neonlinx and it changed the permission but still no luck. I checked with Fetch (ftp app) info and it said permission now was 775 (I even tried to make the permission 777) and the owner was 1000. Could it be an owner issue?


#11

This is possible as that folder should be owned by the user in question.


#12

at one point I actually got a window where the user was listed as user(1000)@… but I cant recreate it.
I guess I will have to contact the seedbox provider to ask if it has been setup correctly. I am also not able to run upgradePLEX so maybe something is generally wrong.


#13