Blank disk space in dashboard

storage
ubuntu
16.04

#1

Hi I’m having an issue with my quickbox installation

It’s running on a kimsufi server with Ubuntu 16.04 installed with the stock distro kernel

Any ideas how to fix this?

This is my fstab file

/dev/sda1       /       ext4    usrjquota=aquota.user,jqfmt=vfsv1,errors=remount-ro,relatime    0       1
/dev/sda2       /home   ext4    defaults,relatime       1       2
/dev/sda3       swap    swap    defaults        0       0
proc            /proc   proc    defaults                0       0
sysfs           /sys    sysfs   defaults                0       0
devtmpfs        /dev    devtmpfs        rw      0       0

#2

Ok, I fixed this by reinstalling without quotas and running the “fix-disk_widget_home” command to set the quota to my /home mount

I’d like to know how to properly fix this for future reference if someone doesn’t mind answering though :slight_smile:


#3

There is no need to reinstall your server (for future reference). You may simply remove the Quota package from your server by way of the Dashboard via the Package Management Center, or by way of box using box remove quotas.

Additionally, if you are going to have multiple users on your system, you can set their diskspace by the command shown after install. This command is setdisk. For more QuicBox commands, check this Wiki out.


#4

I’m seeing an issue as well, where my Disk Status shows GB, with no number. This was after installing quotas, over an existing QB install, setting disk for both users and running fix-disk_widget_home.

What do I do next? Or is a reboot reccomended after quotas install? Removing quotas again is a temp fix, but I’d like to make use of quotas.


#5

I’m checking into this once someone provides me details to their server so I may investigate this issue directly.


#6

Was this issue ever fixed? I Had to reinstall my server do to my own stupidity. so today I decided to run the updater after I got all my data finally in position. After running the updater I’m getting a blank disk usage widget.

See here: https://i.imgur.com/yL5BbYP.png

I don’t have quota installed because this is my personal machine and i’m the only user. I’ve tried running the fix-disk_widget_root cmd and i just get this:

10362/16003MB 3.01 0.95 0.34 1/425 3320 [3278:3065 0:180] 06:12:41 Wed Sep 06 [[email protected]] ~ (1:180)# fix-disk_widget_root cp: cannot stat '/etc/QuickBox/themes/defaulted/widgets/disk_data.php': No such file or directory chown: cannot access '/srv/rutorrent/home/widgets/disk_data.php': No such file or directory
im kinda stuck cause i don’t really know where else to look for error since my new to the whole linux thing. (hence why i had to reinstall in the first place.)


#7

I will update this shortly. The file structure changed to make it easier for those wishing to submit additions/features to the dashboard. I’ll post the commit shortly, thanks for bringing this up.

Ok, you can run the box upgrade command or update from your dashboard. If you find the command still not working do source /root/.bashrc and try once more.


#8

Worked like a charm, Ty sir!


#9

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.