Bash/ssh commands hangs/not responding after installing QuickBox


#1

I just install QuickBox 2.4.7 on a fresh install of Ubuntu 16.04 server. After the installation, bash/ssh commands sometimes freeze/hang, and the cursor just keeps blinking indefinitely. This happens to non-QuickBox scripts as well as with some QuickBox commands. Only wait to exit is pressing “clt + c”. For example this will freeze for me:

root:~# box install csf
Installing csf Installing and Adjusting CSF (this may take bit) ...

Before installing QuickBox into the Ubuntu server, this wasn’t an issue. For example, I can run “vainfo” before but get the same error as above if I run it after QuickBox has been installed.


#2

QuickBox would have nothing to do with any commands that are not created by the QuickBox eco-system; i.e, Package Installers. The bash environment is the same as with default linux and all we have done is added color aliases and additional directory aliases, as well as QuickBox specific functions (e.g: upgradePlex and createSeedboxUser etc.)

If your system is hanging this is more than likely a product of a failed dependencies install. This can happen while a dependency is being installed on your system, this will then create a temp .lock file to inform the OS that “something” is being installed and to not interrupt. If this process does get interrupted or prematurely canceled while it’s in the process of installing (see Ctrl + C) then this lock will be in place until it is either manually removed, or the server is rebooted.

Again, this has nothing to do with QuickBox as I promise… after over 1,000 installs and this being the first report… this is not a bug within QuickBox, yet it is standard Linux behavior.

Run apt-get update and see if a lock is in place. You can then rm the specific lock, run dpkg and apt-get -f install and attempt to install your dependencies once more.

In regards to CSF…

It just may, as CSF requires sendmail binaries to successfully install. If, for whatever reason, the system seems to hang for an unusual amount of time… best practice is to hit Enter and allow a minute for it to continue as sometimes unattended installations do present non-view-able prompts.