Autodl-irssi problem after Quickbox Update

autodl

#1

Hi,

yesterday I updated Quickbox to last version. But today I found a problem with Autodl-irrsi:

Error downloading files. Make sure autodl-irssi is started and configured properly (eg. password, port number): Could not read file autodl.cfg: AJAX error, status: error, Exception info: Not Found

in recent weeks I have not touched anything. The only thing I did (exactly two days ago) was to change some settings in the AutoDL-irssi filters.

Any Idea? I’ve tried restarting irssi from the dashboard but I had no success. I also did a “killall irssi”, then restarted. From the rutorrent log seems to start properly (check for update, register nick on irc servers, etc…) but when I click on (for example) “filters”, it shows that error message.

EDIT: having the need to turn off 2 IRC server, I modified the autodl.cfg file. However when I try to install it (using the RESTORE command from RuTorrent) I get this error:

JsonSocket: Aborting, Timde out!
GuiServer: Error Getting JSON Data: JsonSocket Timde Out!

EDIT 2: I tried to restart autodl-irrsi; I tried to clear system mem cache and browser cache; I tried to set permission to autodl.cfg to 755 (insted of 644);

These are my settings (I never touched anything; I only changed the port in December, when I installed QuickBox ):

+++++++++++++++++++++++++++++++++++++++++++++++
autodl2.cfg: (has permission 644)
+++++++++++++++++++++++++++++++++++++++++++++++
[options]
gui-server-port = 49354
gui-server-password = xxxxxxxxxxxxxxx

+++++++++++++++++++++++++++++++++++++++++++++++
.rtorrent.rc: (has permission 644)
+++++++++++++++++++++++++++++++++++++++++++++++
network.port_range.set =49000-55000
network.scgi.open_port = localhost:53000

++++++++++++++++++++++++++++++++++++++++
/srv/rutorrent/conf/conf.php:
++++++++++++++++++++++++++++++++++++++++
$scgi_port = 5000;
$scgi_host = “127.0.0.1”;

+++++++++++++++++++++++++++++++++++++++++++++++
/srv/rutorrent/plugins/autodl-irssi/_conf.php
+++++++++++++++++++++++++++++++++++++++++++++++
$autodlPort = 0;
$autodlPassword = “”;


#2

Could you humor me and attempt to reboot your server? The update doesn’t do anything with user directories and/or config files already in place, nor does it touch permissions. I have heard of a few instances with this happening and 9 times out of 10 a server reboot set everything solid again.


#3

Ok thanks…

It’s ridiculous … but it’s the only thing I have not thought to do … I would have to do that first.:blush:

Anyway, I’ll try as soon as possible, because at the moment I’m doing an upload from my home computer. Just done, I’ll let you know if everything was resolved and I will edit this post.


#4

Hi,

sorry for the delay…I restarted my server but unfortunately the problem is still there…I don’t know what to do…Can I reinstall only Autodl-irssi??


#5

you can try to run
cpan Archive::Zip Net::SSLeay HTML::Entities XML::LibXML Digest::SHA JSON::XS

from root, that help me last time i had a a problem.

but frist try to se if screen i running screen -list then there should be some xxx.irssi
run screen -r xxx (for .irssi)
or try
/srv/rutorrent/plugins/autodl-irssi/_conf.php
set the same port and password as autodl2.cfg:.
rename _conf.php to conf.php


#6

Thanks…

but I have no success. Anyway, irssi screen is running. If I restart Autodl-irssi, seems (from rutorrent log) that it is running. Infact it checks for update, it says that it is listening on port xxxxx, it enters IRC channels…but if I click on filters, or other settings, nothing happens and it shows that error message.


#7

I do not know why I have not thought of before…I created a new, clean autodl.cfg file. And now it works. But, anyway, it’s very strange because I didn’t touch anything in autodl config. This error appeared from day to day without having changed anything in the filters or in the settings. And I spent the last few days to analyze the file to look for a possible error and found nothing.

Very Absurd.

SOLVED: I’m awesome…and I’m very stupid…I found the error…about 3 weeks ago I copy-pasted the name “Beyoncè” from a famous music tracker to made a filter (yeah I’m very lazy…). Don’t know why but in autodl-irssi it became “Beyonc�”!!! So I corrected that symbol and now works perfectly. The only thing that I don’t understand is: why autodl-irssi with that filter works for so many days before showing that error message??

Sorry Guys!!! I searched that f*****g error for days!!! :blush: :joy: