Autodl-irssi: Missing PHP modules: xml

rutorrent

#1

This error has cropped up just recently in ruTorrent, I cannot interact with autodl-irssi whatsoever. This setup was working perfectly fine until recently, where a new message has come up:

Error downloading files. Make sure autodl-irssi is started and configured properly (eg. password, port number): Error getting files listing: Missing PHP modules: xml

php-xml has always been installed, and if I run a PHP script to check for the module it is definitely there, so I am not sure why all of a sudden it’s unable to see this plugin as being there.

Also, trying to use box install autodl results in:

shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Installing autodl
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
cp: cannot stat '/etc/quickbox/plugins/autodl-irssi': No such file or directory
/usr/local/bin/quickbox/package/install/installpackage-autodl: line 42: _string: command not found

Even though I have followed proper update procedures based on the README on GitHub. I checked the install file and it isn’t referencing the new paths.


#2

If you are current on QuickBox (should be a version bump today to v2.5.4) then you should be able to run the command upgradeIRSSI. Please run that (as there will be more on this today as well) and let me know your results. More than likely, something in your settings got wiped (I wouldn’t know how) and your config paths for xml aren’t present. Please let me know how that command works out for you. Also, the box install autodl command is pulling a very old version of autodl-irssi and is currently being updated to pull in v2.1.0.


#3

The output of upgradeIRSSI -u=myuser seems to indicate everything went OK:

✔ Processing arguments...
✔ Done!
✔ Updating QuickBox users .irssi...
✔ Done!
✔ QuickBox User .irssi update completed!
################################################################

 >> User      : myuser .irssi updated!

################################################################

However, I still experience the same issue as before.


#4

Could you please post the results of php -m in your ssh terminal


#5

Sure, here ya go:

[PHP Modules]
calendar
Core
ctype
date
dom
exif
fileinfo
filter
ftp
geoip
gettext
hash
iconv
igbinary
json
libxml
memcached
msgpack
openssl
pcntl
pcre
PDO
Phar
posix
readline
Reflection
session
shmop
SimpleXML
sockets
sodium
SPL
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlwriter
xsl
Zend OPcache
zlib

[Zend Modules]
Zend OPcache

#6

Well, it’s all there. Could you (just for fun) type phpenmod xml, then issue a restart to rTorrent from your dashboard or via the usual systemctl restart [email protected]<USERNAME>. I am not able to duplicate this, but I can see others are having the issue as well.


#7

Tried both of these, unfortunately the issue still persists. I would try rebooting but I have a task running I can’t pause which won’t be done for some time.


#8

Try this one instead… long day here… phpenmod -v 7.0 xml


#9

Tried that, unfortunately no difference.


#10

Did you follow it up with service php7.0-fpm restart and service apache2 restart? Not sure why the module would be loaded and Autodl-irssi suggesting otherwise. I’ll keep looking into it.

Also, what version were you coming from that you followed the readme update and what version are you on now?


#11

Yeah, I did, doesn’t seem to have changed anything.

Honestly I can’t tell you what version I used to be on, I can tell you I hadn’t updated for a couple months though. I’m updated to the most recent commit 8cd699b. I’ll give a reboot a shot in a couple hours. I do have my autodl config all backed up, so I can also try purging it and re-installing (what would be the recommended way of doing this? box remove autodl && box install autodl?)


#12

I would say give that a shot since you’re all backed up.
Run this instead removepackage-autodl then installpackage-autodl.


#13

Tried both, didn’t seem to have any success unfortunately. I guess I can live without it since everything else related to irssi works fine though in the interim (unless it turns out my system is just messed up).