Apt-get update (for upgrading Emby) not working


#1

Hi All

I wish to upgrade Emby through apt-get, but I am having issues with the ‘sudo apt-get update’ command, as shown below:

(1:171)# sudo apt-get update
Get:1 http://ppa.launchpad.net/deluge-team/ppa/ubuntu precise InRelease [13.3 kB ]
Hit:2 http://ppa.launchpad.net/ondrej/php/ubuntu xenial InRelease
Hit:3 http://ppa.launchpad.net/webupd8team/java/ubuntu xenial InRelease
Hit:4 https://apt.sonarr.tv master InRelease
Hit:5 http://ppa.launchpad.net/x2go/stable/ubuntu xenial InRelease
Hit:6 https://downloads.plex.tv/repo/deb public InRelease
Ign:1 http://ppa.launchpad.net/deluge-team/ppa/ubuntu precise InRelease
Hit:7 http://download.mono-project.com/repo/debian wheezy InRelease
Hit:8 http://download.mono-project.com/repo/debian wheezy-libjpeg62-compat InRel ease
Hit:9 http://download.mono-project.com/repo/debian wheezy-apache24-compat InRele ase
Ign:10 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04 InRel ease
Hit:11 http://download.opensuse.org/repositories/home:/emby/xUbuntu_16.04 Relea se
Hit:13 http://archive.canonical.com/ubuntu xenial InRelease
Hit:14 http://archive.ubuntu.com/ubuntu xenial InRelease
Get:15 http://archive.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Get:16 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Get:17 http://archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
Get:18 http://archive.ubuntu.com/ubuntu xenial-security/main Sources [127 kB]
Get:19 http://archive.ubuntu.com/ubuntu xenial-security/main amd64 Packages [518 kB]
Get:20 http://archive.ubuntu.com/ubuntu xenial-security/main Translation-en [222 kB]
Get:21 http://archive.ubuntu.com/ubuntu xenial-updates/main Sources [311 kB]
Get:22 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse Sources [8,408 B]
Get:23 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [803 kB]
Get:24 http://archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [331 kB]
Get:25 http://archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [640 kB]
Get:26 http://archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages [16.4 kB]
Fetched 3,314 kB in 8min 3s (6,851 B/s)
Reading package lists… Done
W: GPG error: http://ppa.launchpad.net/deluge-team/ppa/ubuntu precise InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY C5E6A5ED249AD24C
W: The repository ‘http://ppa.launchpad.net/deluge-team/ppa/ubuntu precise InRelease’ is not signed.
N: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I am on Ubuntu 16.04.3 LTS. Any suggestions on how I can fix the above?

Thanks for your help!
G


#2

try
sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com C5E6A5ED249AD24C
sudo apt-get update