Apache & SSL :80 forward to :443


#1

Hi guys,

I know the answer is somewhere on these forums, but for the life of me I cannot find the post.

I’m setting up another build of QuickBox, but can’t find which file it is I need to edit.

There’s a conf file SOMEWHERE in /etc/apache2 (I think) that when you hit https://my.seedbox.net:80 it auto forwards to :443 before asking for a password.

Anybody hazard a guess at the location of said file?

I still have access to my old server, so once I know the location I can copy the contents.


#2

I swear there’s a magical power to this forum. The moment I ask the question I find the answer.

For my future self and others who are trying to do the same.

Edit the file /etc/apache2/sites-enabled/default-ssl.conf
In the section titled:

<VirtualHost *:80>

add the following line just before:
</VirtualHost>

The line to add is:

Redirect permanent / https://my.subdomain.net/


#3