Add Koel to QuickBox (with Box)

music
newapp
testing
koel

#1

Hello everyone,

Koel is a personal music streaming server which permits to stream your downloaded music directly from your server. It’s a spotify-like and seems to be one of the best self-hosted app to listen your music (with Sonerezh).

Currently there is no official mobile client (I believe) to use it with offline-mode on your phone but you can listen music from any mobile browser (tested with Google Chrome).

Website: http://koel.phanan.net/#!/home
Demo: http://demo.koel.phanan.net/
Github: https://github.com/phanan/koel
Documentation : http://koel.phanan.net/#install

Currently I did the automatic installation script (installpackage-koel) and it works well on Ubuntu 16.04. If some of you shows interest in this application, I could create the other files needed to integrate Koel easily into your Quickboxes (removepackage, apache conf and dashboard web service management as it can be started/stopped).

Does some of you are interested ?
Thanks!


#2

Hello,

I’m finishing the Koel scripts for the QB integration but I had some issues with the Apache Koel configuration. I’m not an Apache power-user (certainly why I fail to configure it) but I guess to know the basics.

Koel is accessible on http://serverip:8000 like other application as CouchPotato (:5050), PlexRequests (:3000), etc. So I simply need (I guess), to redirect the 8000 port to the URL http://serverip/koel.

But when I create the “koel.conf” file in /etc/apache2/sites-enabled, reload the Apache2 service and go to the adresse http://serverip/koel, I add a black screen with “Not found” (<-- seems to come from the Koel application because it’s with Koel’s design).

I tried several combinaisons of koel.conf but no one was OK.

Above the settings from my koel.config (I want Koel to be public like PlexRequests) :

<Location /koel>                                                                                                                                                               
ProxyPass http://localhost:8000/koel                                                                                                                                           
ProxyPassReverse http://localhost:8000/koel                                                                                                                                    
Require all granted                                                                                                                                                            
</Location>                                                                                                                                                                    

After restaring Apache2 service, I got this :

Do you have any idea why it’s not working ?
If you need to do real tests, I can set up for you a 2 hours VPS with Koel installed.
Thanks!

EDIT : for now, it seems impossible regarding this topic : https://github.com/phanan/koel/issues/32#issuecomment-164521990
I will let the default port 8000 :wink: