503 Sonarr and Running Under Wrong User



When I installed QB I created a user called “admin”. I then created a new user called “syssu”.

Today I noticed when I went to Sonarr under the syssu user all my settings and shows were gone. When I went to the status of Sonarr for “Syssu” it showed its configuration at /home/admin/.config/NzbDrone which does not seem correct to me. I then restarted the service in the QB admin which did not seem to do anything so I tried to restart it from within Sonarr. Upon restarting in Sonarr the endpoint to the app just gave me a 503 error every time.

I then went under root in SSH and did box remove sonarr and then installed it again under the Syssu user on the QB dashboard. Now everything appears to be working except for some missed shows because I think it was running under the wrong user. I have a suspicion that if I restart the OS this will happen again, as this is not the first time I ran into this issue.

Has anyone ran into issues like this, and what should I do to resolve them?