503 error after installing Plex

debian8
plexmediaserver
plex

#1

Hi,

after installing Plex, from dashboard and with box install plex, I’m still getting this eror :

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Can someone help me ?

Running on Debian 8

Thanks :slight_smile:


#2

try running ubuntu 16.04


#3

There is no other solutions ? It cant be installed via ssh manually ?


#4

you could try installing plex manually but as i know ubuntu 16.04 works that’s the reason i suggest it


#5

Hello,

I found way to install PMS correctly on Ubuntu 16.04.

If you have already installed Plex and it’s currently not working (otherwise, jump this part) :

su root

Uninstall PMS with :
box remove plex
apt-get purge plexmediaserver -y (to be sure)

Modify the PMS Quickbox install script :
nano /usr/local/bin/quickbox/package/install/installpackage-plex

Modify the script with theses updates :

Comment the line 38 : #wget -O - http://shell.ninthgate.se/packages/shell.ninthgate.se.gpg.key | apt-key add -

Comment the line 39 : #echo "deb http://shell.ninthgate.se/packages/debian jessie main" > /etc/apt/sources.list.d/plexmediaserver.list

Add these lines under the previous commented section :

wget -q https://downloads.plex.tv/plex-keys/PlexSign.key -O - | sudo apt-key add -

echo "deb https://downloads.plex.tv/repo/deb/ public main" > /etc/apt/sources.list.d/plexmediaserver.list

Add this line under the “Updating system” echo : apt-get install apt-transport-https -y

Add -o Dpkg::Options::="--force-confold" to the line 46 :
apt-get install -o Dpkg::Options::="--force-confold" -y -f plexmediaserver >/dev/null 2>&1

You should have the same things as this file : https://github.com/PastaGringo/scripts/blob/master/installpackage-plex

After that, simply connect to the Quickbox dashboard, refresh the web page and install PMS with the interface :wink:


#6

did you test it on Debian ?


#7

Not yet, i’m leaving work I will test with debian tonight :wink:


#8

I tested the modifications on fresh Quickbox VPS installation with Debian 8.6 and that works.
Plex has green icon and the PMS is reachable at http://serverip:31400 :slight_smile:


#9

Nice :slight_smile: I’m going to test right now, thanks for your time


#10

Ok … Bad news, still not working ): EDIT : But if I disabled/enable Plex from the interface, the button is green, but it’s not working


#11

Could you check the PMS state with sudo service plexmediaserver status ?
PS : on pourrait parler français mais bon :smile:


#12

On va dire que c’est pour les autres personnes qui ont le même problème :stuck_out_tongue:

If i run sudo service plexmediaserver status, I get this :

● plexmediaserver.service - Plex Media Server for Linux
Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled)
Active: failed (Result: start-limit) since Tue 2016-12-13 20:56:35 CET; 3s ago
Process: 6254 ExecStart=/bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver /usr/lib/plexmediaserver/Plex\ Media\ Server (code=exited, status=134)
Process: 6250 ExecStartPre=/bin/sh -c /usr/bin/test -d “${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}” || /bin/mkdir -p “${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}” (code=exited, status=0/SUCCESS)
Main PID: 6254 (code=exited, status=134)

Dec 13 20:56:30 x systemd[1]: Unit plexmediaserver.service entered failed state.
Dec 13 20:56:35 x systemd[1]: plexmediaserver.service holdoff time over, scheduling restart.
Dec 13 20:56:35 x systemd[1]: Stopping Plex Media Server for Linux…
Dec 13 20:56:35 x systemd[1]: Starting Plex Media Server for Linux…
Dec 13 20:56:35 x systemd[1]: plexmediaserver.service start request repeated too quickly, refusing to start.
Dec 13 20:56:35 x systemd[1]: Failed to start Plex Media Server for Linux.
Dec 13 20:56:35 x systemd[1]: Unit plexmediaserver.service entered failed state.


#13

I think PMS was not really uninstalled from your server and the service has some troubles to start.
I’m on the QuickBox IRC if you need some help (send me PM if you need help to connect to it).


#14

same problem here, new box installation with ubuntu 16.04… Whats up with quickbox´s scripts?


#15

they work just fine.


#16

Installed Ubuntu 16.04, not working with dashboard but working with box install plex