3 questions regarding apps


#1

Hey guys,

I’ve three questions regarding some applications and wanted to put them together in one thread to make it easier. So the first one is about Quassel:

  • I’ve been having problems with Quassel for the past weeks (haven’t had much time to dig deeper into that tho). The problem here is: I can’t connect to the core aynmore. I could in the past tho. But something changed, I don’t know. I reinstalled Quassel on my Kimsufi again, I opened the Windows client, tried to connect to the core using the login credentials that I’ve always used to log in into my server. But everything I type in is incorrect. Did the port change? Or can I completely remove Quassel and everything that comes with it? I really have no idea how to solve this problem.

The second question deals with SickRage:

  • I installed SickRage, went into the configuration, adjusted some things (nothing special), I entered my log in information for IPT and some other trackers, added 4 TV shows, but yeah… nothing happens.
    For example, for Westworld SickRage tells me: Snatched(720p-WEB-DL). But doesn’t it mean that rTorrent is somehow downloading it now? I didn’t find the torrent in the list and the folder is empty, too.
    Do I have to do something else with SickRage? Like telling it where it can find rTorrent? Also the log file isn’t telling me anything important.

And then I have a third question regarding NextCloud:

  • How can I “connect” my NextCloud folder with the downloads folder of rTorrent? The reason is that I want to access my movies and tv shows and stream it with my FireTV box. So I either want to:
  • add a folder to NextCloud, something like a shortcut so that NextCloud can access the rTorrent download folder, or:
  • move all the torrents to the home NextCloud folder respectively tell rTorrent that the downloads folder is the NextCloud home folder. But I think that the NextCloud folder is hidden because I can’t access it with rTorrent.

So I hope you can help me with my issues =)


#2

Maybe i can help you out with SickRage.

Go into ‘General’ -> Search Settings -> Torrent Search and pick rTorrent as Torrent Searcher.

Under host just add: scgi://localhost:XXXXX/

Where XXXXXis your rtorrent port, which is located in .rtorrent.rc file

And ofc. Downloaded files location where you store your downloaded torrent files. Mine is set by default: /home/USER/torrents/rtorrent

Cant really help you out on the other two questions :frowning:


#3

The nextcloud question!!

I found an official extension for nextloud to load “external” drives.

I just pointed it to my media folder, worked a treat.

If you need more help finding the extension let me know, but it was inside the nextcloud interface.

Edit: if you want to go hardcore @JMSolo wrote a help article on it:

be warned though, permissions can be tricky with this method :slight_smile:

Edit
Steps to add the external storage module:

  1. Top left icon, tap + apps

  2. Enable External storage support

  3. Top right corner, select admin panel

  4. Choose ‘External Storage’ from the left side

  5. Add your directories and share with the users you like

out of curiousity, @JMSolo what are the security implications of adding the seedbox user to the www-data group? The reason I ask is files uploaded this method are owned by www-data & if I want to do anything with them I need to chown them manually.


#4

Sorry guys for my late reply, the last hours were really busy…

@Titte95
Thank you for your help, your solution worked! =)

@valkyre14
Thank you also for your help! But if you say it can get tricky with the permissions I might stay away from that and see what @JMSolo suggests since he’s the brain of the software and knows about the security things.
Is it also possible to unchain rTorrent from the /home directory? I’d like to point the download folder to the root folder of NextCloud, but I can’t swich to /usr because yeah… the highest level is /home. Can’t go higher.


#5

@cinory
I didn’t follow @JMSolo guide correctly (still not entirely sure how), but caused major permissions issues with my /home/ directory. He was an absolute gentleman and fixed it up for me, but it scared me off.

If you follow the method I posted above you’ll be able to mount your download folder as an “external” storage option, allowing you to add your downloads directory to nextcloud (it’s how I’ve done it in the screenshots).

instead of using
/home/gareth/media

you would use: (replacing cinory with your username)
/home/cinory/torrents

This method I found to be much more user friendly (no terminal hackery).

If you need help let me know :slight_smile:


#6

@valkyre14

I tried your method and it worked perfectly! So thank you a lot for your helpful response :slight_smile: I can stream everything, it’s great =)

I’m only dealing with SickRage and Quassel now. SickRage is now able to find the torrent and pass it on to rTorrent in order to download it. But once rTorrent receives the torrent file it doesn’t start downloading :frowning: Any idea why?


#7

Glad the next cloud stuff worked.

How are you passing the file to rtorrent. I use sick rage with tbe SCGI method. It works without a hitch


#8

I’m using your SCGI method from ealier. The torrent file itself is being passed to rTorrent and appears in the list. But it doesn’t start to download. It still looks like this:


#9

that’s really strange…

In settings - Connection your max number of download slots is set to 0 ?

rtorrent for me just starts, I had a quick look in sickrage. I couldn’t even see an option to “pause when adding”


#10

I’ve these settings:


#11

mine are identical.

& sickrage looks like this ?


#12

Yep, my SickRage looks like this:

I mean the port must be right, or? Otherwise rTorrent would receive the torrent file…


#13

Yeah it’s different for every build. In sorry I haven’t seen that before.

Does the black hole method also start paused


#14

The funny thing is: Even if I start the torrents manually by right-clicking 'em they don’t start downloading… so weird :smiley:


#15

I wonder if it’s a permissions issue with the download destination. @liara have you seen this issue before?


#16

If I were you, I’d connect into rtorrent and see what is happening:

  1. ssh into the server
  2. screen -r rtorrent
  3. Watch a torrent import and look for issues
  4. Ctrl-A D to get back out of the screen

#17

Permissions issue for sure.

Does the download folder exist and is it owned by the user of rtorrent? At the very least, it would require global write permissions if you were doing something custom like to your setup.

It looks like it’s in default… I would just make sure the owner of the folder and the permissions of the destination are 755