2.4.0 - Disk Quota Widget shows Wrong Partition after uninstall of the Quota Feature

bugs

#1

I dunno why this reoccurred after you fixed it in a unreleased beta but some how my widget got reset back to the / partition and not /home


#2

Yeah, this is one of those unfortunate unavoidable’s that have occurred as it needs to do a force update on the widget in order to process the new additions to the widget itself.

You should be able to do the past adjustments to set this right:

dashboard
cd widgets
rm disk_data.php && mv disk_datah.php disk_data.php

QB 2.4 - How to enable single user quotas?
#3

after a full reboot that fixed it


#4

These darn reboots. I think you’re the 3rd person to say that a reboot helped it. It may be a requirement as this is a rather large update. I will add that to the instructions.


#5

only after the moving of the widget it forces the software to reload the fixed plugin


#6

So its fixed for me as well. Uninstalled quotas, and had it reporting on /(root) instead of /home.

Followed directions above (as root) and that fixed it. I did not, however, have a disk_datah.php in the same folder, but i was able to find it in /root/QuickBox/dashboard/widgets and I copied it from there to the folder that “dashboard” put me in (/srv/rutorrent/home/widgets).

Now, I just have this crazy % with 10 decimal points, see here: http://imgur.com/gnIQ7ew

Any ideas, is that normal, or did I mess something up and will need to edit the php myself to fix it for now?


#7

the math comes out to be correct (dunno why you have that many zeros tho


#8

Look, you guys DID ask for EXACT numbers :stuck_out_tongue_winking_eye:

That’s actually pretty funny that it reports down that low. I may need to tweak the arithmetic there… I don’t think it should be reporting that low.