2.2.0 Disk Quota Widget

widget
disk
16.04

#1

2.2.0 Fresh Install
Herzner/OVH Box
/Home Option Install
Ubuntu 16.04

This is after setdisk as root


#2

You probably snagged the script right before I implemented an addition to it… I oops’ed a command at the end.

Type this and you’ll be set from here on out… reboots etc.

quotacheck -auMF vfsv1

#3

tried it, no success


#4

Did you reboot after the install?

What is the return on repquota -a


#5

Yes Ive rebooted a half a dozen times

and nothing


#6

Ok, we need more input.

What is the result of repquota -a and lsblk


#7

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
sda 8:0 0 2.7T 0 disk
├─sda1 8:1 0 8G 0 part [SWAP]
├─sda2 8:2 0 512M 0 part /boot
├─sda3 8:3 0 1T 0 part /
├─sda4 8:4 0 1.7T 0 part /home
└─sda5 8:5 0 1M 0 part
sdb 8:16 0 2.7T 0 disk
├─sdb1 8:17 0 8G 0 part
├─sdb2 8:18 0 512M 0 part
├─sdb3 8:19 0 512G 0 part
├─sdb4 8:20 0 2.2T 0 part
└─sdb5 8:21 0 1M 0 part

Nothing on repquota -a


#8

Oh boy… can you tell me the return of cat /proc/mdstat -or- is this two different machines?

Also, show me cat /etc/fstab

It looks like a RAID 1 config and on top of that you have half your space on the root mount and half on the home mount.


#9

Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
md2 : inactive sdb31
536739840 blocks super 1.2

md1 : inactive sdb21
523760 blocks super 1.2

md3 : inactive sdb41
2384349639 blocks super 1.2

md0 : inactive sdb11
8380416 blocks super 1.2

unused devices:

proc /proc proc defaults 0 0

/dev/sda1 during Installation (RescueSystem)

UUID=db9c982d-bb26-4b21-b726-b160bffebf6c none swap sw 0 0

/dev/sda2 during Installation (RescueSystem)

UUID=d6fa5c22-91c6-4150-8897-6a9f6b1969f6 /boot ext3 defaults 0 0

/dev/sda3 during Installation (RescueSystem)

UUID=c7b40e90-69a9-4a94-bd3a-96e67e6d8e5c / ext4 defaults 0 0

/dev/sda4 during Installation (RescueSystem)

UUID=f6a09fe9-ab6f-4165-a448-096dfb841c51 /home ext4 defaults 0 0


#10

Well that’s interesting… it looks like this machine had defaults as it’s setting… that is problematic. What a strange setup.

Try this out:

Modify the /home disk ( nano /etc/fstab) to have changes from this

UUID=f6a09fe9-ab6f-4165-a448-096dfb841c51 /home ext4 defaults 0 0

to this:

UUID=f6a09fe9-ab6f-4165-a448-096dfb841c51 /home ext4 usrquota,errors=remount-ro 0 0

then Save and Exit the file


#11

this is just Herz’s stock setup other then me creating a raid 0

setquota: Cannot open quotafile /home/aquota.user: No such file or directory

now that quota is enabled


#12

Ah, well that is good to know. I am going to make a note of this and have to add this as an option somehow. [if defaults on mount in fstab ] sort of thing.

Did adding that string to your disk bring the quotas to life?

Try to rebuild quotas now.

quotaoff -a
service quota stop
mount -o remount /home
quotacheck -auMF vfsv1
quotaon -uv /home
service quota start

It’s possible it failed to create the quota due to not being able to add the needed edit to fstab on install… so it just bypassed it.


#13

That Worked :smiley: good thing i decided to reformat my box last night :stuck_out_tongue: now its time to finish setting up Sonarr, CouchPotato and my news group reader


#14

Also, make sure your entire 2.7TB of space is being used… just in case and what-not.

I’m definately going to work on setting this in the script… now we know :neutral_face:


#15

ending up it didnt set up as Raid 0 XD going to have to rebuild it again :smiley:


#16

That’s what I said :stuck_out_tongue_winking_eye:


#17

awwww lol i didnt catch it until looking at Sonarr what sucks is i just got those working with SystemCtr


#18

Sounds like me today figuring out jailing Plex for multiple users on a server so it’s confined to individual /home/$user directories… about 15 reinstalls and I think I am close


#19

Yea well i try automating everything for ease of my roommate and his TV and Movie habits :stuck_out_tongue: oh well its now set up correctly and am waiting for it to finish installing and correct the fstab before i install the software


#20

Yeah, just have the /home disk read as

UUID=f6a09fe9-ab6f-4165-a448-096dfb841c51 /home ext4 errors=remount-ro 0 0

That way the script can still do it’s thingy thing.