Sonarr - Unable to connect to indexer, check the log for more details


#41

That maybe true… however ill stand by my comment of being an idiot! Setting up everything again in a day has melted my brain. Ive run a seedbox that i built from scratch a couple of years ago and never messed with it too much. i wanted this as it just has nearly everything without messing with it too heavily and keeping the OS clean


#42

I’m not smarter…I’m just a very seasoned linux admin…like 30 years working on unix-linux.

the apps(if setup correctly) should all listen on ‘localhost’ and not a public IP. It’s a security measure. They can only be accessed on the server itself via that port which is http so insecure. If you want to connect to the actual port of 9117, you’d need to do it from the actual server via VNC or X2Go…by entering localhost here, its saying that my local app(Sonarr) is going to talk to Jackett(also local) via the localhost(127.0.0.1) on that port. It works because they are both local to the server. It never goes against the public IP and thus bypasses the proxy stuff.


#43

I had this issue as well. Except I’m using Jackett on my seedbox, talking to Sonarr on my local server. Thus I am using my domain name. I can only make this work with HTTP, auth disabled and specifying 9117 (don’t worry, I set a Jackett password).

Is it possible to use HTTPS? I want to make sure the data is passed securely.


#44

Hi,
I have the same problem. I tested with this differents addresses (IP adresse, localhost, http, https) but it don’t work.
Do you have some issues ?
PS : I have a question : why Jackett give me this link to integrate for sonarr / Radarr:
https://MY_SERVER_IP/jackett/api/v2.0/indexers/yggtorrent/results/torznab/


#45

Hello @Neibaf

Ygg has changed their website URL, so even if the interaction between Sonarr/Radarr and Jackett was functionnal, you should not have any result :slight_smile:

As we need to do when are facing of this kind of issue, you need to create a new issue directly on Jackett github to tell teme to correct the issue : https://github.com/Jackett/Jackett/issues/2215.

PS : the issue was already created, please use the search bar (/autoflogging)

I can grab results from Jackett with this torznab URL : http://localhost:9117/torznab/YourIndexer


#46

The problem is that Sonarr/Radarr return me a error :
Unable to connect to indexer: HTTP request failed: [401:Unauthorized] [GET] at [https://MY.DOMAIN.COM/jackett/api/v2.0/indexers/yggtorrent/results/torznab/api?t=caps&apikey=MyAPIKey]
and the errors ars same for http, https, IP adress, Domain name address and localhost


#47

Did you try this URL with a working indexer : http://localhost:9117/torznab/YourIndexer ?


#48

yes, same error


#49

Weird.

Could you please show us the result of these commands :

  • netstat -an | grep 9117 | grep LISTEN
  • cat /etc/apache2/sites-enabled/jackett.conf (remove your username after “require user” when you paste the result here please)

#50

I have uninstall sonarr/radarr and jackett for this moment.
I tried again it next week.