Something strange with the new script

thanks for this i have requested the install

  • Documentation:
    Last login: Thu Jun 2 17:49:11 2016 from
    /root/ line 21: bc: command not found
    [root@dedi-fr-38840]:(kb)~# disktest
    16384+0 records in
    16384+0 records out
    1073741824 bytes (1.1 GB, 1.0 GiB) copied, 4.68198 s, 229 MB/s
    /root/ line 21: bc: command not found

Seems the IO is functioning normally. Could be something to do with their image used too. Hopefully we can resolve that on the reinstall once it’s done. I appreciate your patience.

the drives partitions should not affect that but i am wondering how they set up theirs.

Pretty much the same as since they are just resellers for them.

hi guys loving this support

ok the server has been re installed mr solo would you do me the honour from a clean install

Edited to remove password information

Getting in there now. I will keep you posted via Private Message.

Been testing all night works beautifully but this morning i tried adding a user the quickbox control panel works fine for this user but when i tried to access rutorrent i got this

Bad response from server: (200 [parsererror,getplugins]) SyntaxError: Unexpected identifier

never seen this before i deleted the torrent lock and restarted from root well tbh ive done everything i could think of any ideas please

What happens if you do the following:

su _username_
screen -fa -dmS rtorrent rtorrent

This will login you into the users shell and then restart their session. Now type exit to leave their shell and see if the error still appears.


yes done that and it is still the same

[03.06.2016 15:12:39] WebUI started.
[03.06.2016 15:12:39] Bad response from server: (200 [parsererror,getplugins]) SyntaxError: Unexpected identifier

restarted user from root using pkill

nothing changed

Are your details the same as when I installed the script? It’s possible you just have a permissions issue.

When I try to install, I receive this error.

quickbox-setup: line 873: local_rutorrent-plugins=/root/quickbox_rutorrent-plugins: No such file or directory

[QuickBox] QuickBox Seedbox Installation

             Heads Up!
 QuickBox works with the following
 Ubuntu - 14.04 | 15.10 | 16.04
 Debian - 7 | 8

Checking distribution …
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04 LTS
Release: 16.04
Codename: xenial

Congrats! You’re running as root. Let’s continue …

Do you wish to write to a log file? (Default: Y)

I don’t know if the script will continue because I pressed control-c to not break up something.

Hey @tarp, could you go to /root/quickbox_rutorrent-plugins and then run git pull. Then try to run the script for install once more. This happened as I missed a forward slash at the end of repos path.

The folder doesn’t exist. Should I create it and run git pull?

My apologies, my brain was going in two directions, I meant to say go to your /root/quickbox_setup folder and run git pull.

The error went away but then I got this in the log file

mount: /tmp not mounted or bad option

Should I mount something before running the script?

You can safely ignore this message.

mount: /tmp not mounted or bad option

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

It comes from the _logcheck function

if [[ ! -d /root/tmp ]]; then
    sed -i 's/noexec,//g' /etc/fstab
    mount -o remount /tmp >>"${OUTTO}" 2>&1

This will either be negated or improved at a later time… currently it will not affect the install of the script in 99% use-case.

The script has completed and I’m testing the setup. Looks great so far.

Thank you for the support and this awesome script.