Screwed up my Ombi install

ombi

#21

Hey @JMSolo, heard anything back from tidus?


#22

Hi ! Same issue here, server is on a subdomain, just updated manually Ombi and now i can’t use it. I can see some problem while ombi is loading, some 404 errors when loading js scripts (2.js for example). I think it’s a probelm with the rewrite engine, it doesn’t work as expected…

When the browser loads the script, it will retrieve it from the URL
https://my.domain.net/dist/2.js
that’s when error 404 occurs. But if I manually modify the query using the URL
https://my.domain.net/ombi/dist/2.js
the query returns a 200.

Extract from my ombi.conf:

<Location /ombi>
        ProxyPass http://localhost:5000/ombi
        ProxyPassReverse http://localhost:5000/ombi
        Require all granted
</Location>

    RewriteEngine on
    RewriteRule ^/ombi$ https://MYURL/ombi/ [R=301,L]
    RewriteCond %{HTTP_REFERER} "https://MYURL/ombi/"
    RewriteCond %{REQUEST_URI} !^/ombi
    RewriteRule ^(.*)$ /ombi [R=301,L]

Do you have any idea why the rewrite module doesn’t work?

Thx


#23

I think it has been fixed. Someone edited the wiki with this commit message:

After using the previous apache config, it was not working because /dist/2.js was not loading. Someone from Discord suggested that the last rewrite line was incomplete and needed to be /ombi$1. This fixed my reverse proxy issue and it seems this should be how it should be for everyone.


#24

@JMSolo - if you find time in your busy schedule, can you have a look this this one above - potential fix to this issue?


#25

It has not been fixed. The edit fixed an issue probably unrelated to our problem.


Ombi reverse proxy
#26

Alright i got it working. Was quite annoying…

A copy of my ombi.conf (this is default) :
seedbox01:/etc/apache2/sites-enabled# cat ombi.conf
<Location /ombi>
ProxyPass http://localhost:5000/ombi
ProxyPassReverse http://localhost:5000/ombi
Require all granted

seedbox01:/etc/apache2/sites-enabled# pwd
/etc/apache2/sites-enabled

And then this was the big thing, even though it looks filled in, its not. You HAVE to manually type it “/ombi” :

ombiv1

I then simply restarted the ombi service from the dashboard and boom. Everything works.

Hope this helps all!


#27

What version of Ombi is this?


#28

The latest :
image


#29

Unfortunately that’s not the real latest version, we’re all on that already. (JMSolo rolled back to this because it was the last stable version) After this version is where the rewrite engine stuff is needed, and that’s what we can’t figure out. I think the second to last rewritecond is wrong in the rev proxy examples page on ombi repo.


#30

Ah, i wish it would have been posted here so id have known >_< oh well.


#31

I have just released v3.0.3020 that no longer requires the rewrite rule.

That should help you guys!


#32

Thanks @tidusjar, I’ll give this a shot here by the end of my day. Appreciate your work on this. :wink:


#33

I’m having very similar issues. I can access ombi via port :5000, but not through the apache reverse proxy.

ombi.conf file for apache:
<Location /ombi>
Allow from 0.0.0.0
ProxyPass “http://127.0.0.1:5000/ombi” connectiontimeout=5 timeout=30 keepalive=on
ProxyPassReverse “http://127.0.0.1:5000/ombi
Require all granted

My apache error log is flooded with this, although I think it’s unrelated:
[Sun May 06 02:38:53.004311 2018] [:error] [pid 16493] [client 10.100.3.58:49833] PHP Warning: session_destroy(): Trying to destroy uninitialized session in /srv/rutorrent/home/inc/config.php on line 2, referer: https://10.100.0.16/

Here is my ombi log:
mediasrv:/opt/Ombi/Logs# cat log-20180506.txt
2018-05-06 01:47:04.092 +00:00 [Information] Start installing Hangfire SQL objects…
2018-05-06 01:47:04.415 +00:00 [Information] Hangfire SQL objects installed.
2018-05-06 01:47:04.433 +00:00 [Information] Starting Hangfire Server
2018-05-06 01:47:04.435 +00:00 [Information] Using job storage: ‘SQLite Server: Ombi.db’
2018-05-06 01:47:04.435 +00:00 [Information] Using the following options for Hangfire Server:
2018-05-06 01:47:04.435 +00:00 [Information] Worker count: 1
2018-05-06 01:47:04.435 +00:00 [Information] Listening queues: ‘default’
2018-05-06 01:47:04.436 +00:00 [Information] Shutdown timeout: 1.00:00:00
2018-05-06 01:47:04.436 +00:00 [Information] Schedule polling interval: 00:00:15
2018-05-06 01:47:24.505 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 01:47:32.977 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 01:47:33.579 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 01:47:40.870 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 01:53:19.134 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 02:26:59.248 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 02:27:01.575 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 02:27:02.577 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 02:27:03.465 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 02:27:14.906 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 02:27:30.634 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 02:31:40.883 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 02:31:42.772 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 02:31:43.755 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error
2018-05-06 02:31:44.754 +00:00 [Error] StatusCode: InternalServerError, Reason: Internal Server Error

Running Version 3.0.3293

I get a white screen with just “Loading . . .” on it.


#34

Ok, it started working once I upgraded ombi manually to the latest.

However one issue I found is that now that systemd startup script isn’t working for it. I can boot up a screen session though and start Ombi manually just fine.


#35

It turns out that when I manually upgraded, the permissions for ombi were set wrong.

So what you’ll want to do is chown everything under /opt/Ombi to the user that’s set as the service user in /etc/systemd/system/multi-user.target.wants/ombi.service.

Everything seems to be working good now.


#36