rTorrent doesn't start anymore

Hi Here,

I read some topics about the same issue. Since I updated the box rTorrent is not started anymore.
I tried to do an apt -y install rtorrent and systemctl restart rtorrent@USERNAMEHERE but the service is running only during one minute when I can see activities on ruTorrent but it crash suddenly.
I also tried systemctl restart [email protected] but there is no differences.

Could you please help me?

Thanks a lot


I’m not sure about it being the most correct way to do it, but I personally like troubleshoot rtorrent by ssh-ing in to the server as the seedbox user and just running the command rtorrent, when it crashes, it will output whatever is wrong straight to the console.

If you want a more robust logging solution, I recommend following the first reply in this thread:

(Hint: rtorrent.rc can be found in /home/seedboxUserHere/.rtorrent.rc).
So, whenever it crashes, you can inspect the log at /tmp/rtorrent.log.pidnumber.

I also tried rtorrent command without success before to do all commands I did.

Could you please share the output you get, when trying to run the rtorrent command?

(16:32:43) Using ‘epoll’ based polling.
(16:32:43) Using ‘epoll’ based polling.
(16:32:43) Using ‘epoll’ based polling.
(16:32:43) Could not read resource file: ~/.rtorrent.rc
[Throttle off/off KB] [Rate 0.0/ 0.0 KB] [Port: 6990] [U 0/0] [D 0/0] [H 0/32] [S 0/1/768] [F 0/128]

I also tried to updade from 2.4.9 to 2.5.0 by following this tuto: https://quickbox.io/qb-source-code-is-moving-to-github/

But I have this error when doing a updateQuickBox command:

/usr/local/bin/quickbox/system/updateQuickBox: line 534: unexpected EOF while looking for matching `’’
/usr/local/bin/quickbox/system/updateQuickBox: line 537: syntax error: unexpected end of file

and I also tried to get a rtorrent status which returns:

systemctl status rtorrent@user
[email protected] - rTorrent
Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sun 2017-12-03 16:50:53 CET; 38s ago
Process: 8945 ExecStop=/usr/bin/killall -w -s 2 /usr/bin/rtorrent (code=exited, status=1/FAILUR
Process: 8753 ExecStart=/usr/bin/screen -d -m -fa -S rtorrent /usr/bin/rtorrent (code=exited, s
Process: 8751 ExecStartPre=/bin/rm -f /home/%I/.sessions/rtorrent.lock (code=exited, status=0/S
Main PID: 8755 (code=exited, status=0/SUCCESS)

Dec 03 16:50:30 systemd[1]: Starting rTorrent…
Dec 03 16:50:30 systemd[1]: Started rTorrent.
Dec 03 16:50:53 systemd[1]: [email protected]: Control process exited, code=exited
Dec 03 16:50:53 systemd[1]: [email protected]: Unit entered failed state.
Dec 03 16:50:53 systemd[1]: [email protected]: Failed with result ‘exit-code’.

If I do a fresh install from scratch but just by using the usual quickbox install commands; will I lose my data in my torrent folder and will it be still possible to reuse the same user and the same data in ruTorrent and in Plex?
I have the feeling that I have to reinstall everything clean. But I scare to lose data. :slight_smile:

Hello @corend

I’m advising you to understand what happend with your rtorrent service.
First, you will learn how rtorrent works and you will have more experience with Linux and secondly you will not lose anything if you don’t reinstall your server from scrach :wink:

Do you still have this error ?

You need to ls -al your master home directory in order to find your .rtorrent.rc file.

If it not exists, please look how the setup configured it during your first installation : https://github.com/QuickBox/QB/blob/a51bd62d006b85aead13266aa106e7af6e826277/setup/quickbox-setup#L971

You should be able to reproduce it :wink: (please always do backup files before modifying them)

I do believe that it will be better if I reinstall Quickbox so I will have a proper installation with the correct last version.
The thing is that on Hetzner if I do a reinstall then I will have to execute the install commands in Rescue mode and not via the Quickbox web console, do you confirm that?

Simply executing the normal installation commands do you confirm it will work and without losing my media data for plex?

apt-get -yqq update; apt-get -yqq upgrade; apt-get -yqq install git lsb-release;
git clone https://github.com/QuickBox/QB /etc/QuickBox &&
bash /etc/QuickBox/setup/quickbox-setup

secondly you will not lose anything if you don’t reinstall your server from scrach :wink:
That’s confusing me, a bit :smiley:

I never had a Hetzner server but I guess the rescue mode “logic” is to reboot the server and boot from a minimalist operating system to access to your server and troubleshoot it, as explained here :

The Hetzner Rescue System is a Linux live environment that allows you to have administrative access to your server. The environment starts from the network (PXE boot) and runs in the memory of the server. This makes it possible to carry out repairs to the installed system, to check file systems or to install a new operating system.

So executing QuickBox installation commands from the rescue mode won’t work.
That’s why I advised you to find the issue with rtorrent instead of reinstalling it (much less pain).

If you absolutely want to reinstall it, you will need to copy your data somewhere, reinstall your server and copy back you data.

Thx for your tips. You confirmed my assumptions.

:slight_smile: your rtorrent is always down?